Support » Fixing WordPress » WordPress conflicting with PageLines

  • I have noticed that I am unable to edit my wordpress pages via PageLines5 after update to WP 5.5.

    These are the errors in my site when try to edit a page:

    Uncaught ReferenceError: wp is not defined at color-picker.min.js:2

    Uncaught TypeError: a(...).wpColorPicker is not a function at editing.js:5

    • This topic was modified 2 years, 1 month ago by BenS..
Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    Try installing https://wordpress.org/plugins/enable-jquery-migrate-helper/

    See if your plugin has an update… Because you’re using a commercial theme/plugin, please use their official support channel. We feel they are best equipped to support their products.

    https://www.pagelines.com/support/

    Commercial products are not supported in these forums.

    I have some problem, wordpress with PageLine framework, i can’t edit pages, i install plugin enable-jquery migrate helper, still have same problem i can’t edit my pages on pageline
    Screeshot

    • This reply was modified 2 years, 1 month ago by mehdirochdi.
    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    @mehdirochdi Please see my previous reply. It contains a link to pagelines support.

    temporary i solved the problem,
    look at the file edit.js in directory wp-content/plugins/pl-platform/engine/ui/js
    after unminify a file make comment in this line
    line 886 //else if ("color" === b.type) e += a.engineOpts.coloroption(b)
    after updated a file, i suggest to delete a cache browser

    • This reply was modified 2 years, 1 month ago by mehdirochdi.
    • This reply was modified 2 years, 1 month ago by mehdirochdi.

    I found that the @mehdirochdi fix disables the color-picker, I found another fix for the same file (pl-framework\engine\ui\js\editing.js) that puts a form field in place of the defunct color-picker from stackoverflow:
    Unminify editing.js and replace:

    .each(function () {
    a(this)
        .wpColorPicker({
            change: function (b, c) {
                var d = a(this);
                d.val(d.iris("color")).trigger("keyup");
                var e = _.debounce(
                    function () {
                        d.trigger("blur");
                    },
                    300,
                    { leading: !1 }
                );
                e();
            },
        })
        .addClass("is-ready loaded");
    })

    With:

    .each(function () {
    if(a(this).hasOwnProperty('wpColorPicker')) {
        a(this)
            .wpColorPicker({
                change: function (b, c) {
                    var d = a(this);
                    d.val(d.iris("color")).trigger("keyup");
                    var e = _.debounce(
                        function () {
                            d.trigger("blur");
                        },
                        300,
                        { leading: !1 }
                    );
                    e();
                },
            })
            .addClass("is-ready loaded");
        }
    })
    • This reply was modified 1 year, 7 months ago by 3ark5hipley.
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WordPress conflicting with PageLines’ is closed to new replies.