Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » WordPress Comments Not Correctly Nesting

  • Resolved the5krunner


    This is correctly set: Settings>Discussion>Enable threaded (nested) comments 2 levels deep

    when anyone replies to a comment on my site the comment is not nested but rather added at the end of the list.

    When I reply to a comment in Dashboard>comments then it IS correctly nested.
    When I reply to a comment on a post it is NOT correctly nested.

    I have tried
    – reinstalling jetpack and
    – changing various comment (nesting) options
    – clearing caches
    – enabling and disabling comment caching in litespeed (cache commenters, cache logged in users), cache comment form is off,

    none of it makes any difference

    thank you for any insights!

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Bruce (a11n)


    Happiness Engineer

    Hi @the5krunner

    Thanks for letting us know what you’ve done so far! There still may be something else installed on the site that’s causing problems.

    The best way to find out if something is interfering is to test for a theme or plugin conflict. You can do that by following these steps:

    Temporarily deactivate all plugins except Jetpack, and clear your browser’s cache.

    – Then, try the nested comments again. If nested comments works, then you know another plugin is conflicting here. You can reactivate plugins one by one, checking the nested comments after each one to discover which plugin is causing the problem.

    You can leave that plugin deactivated and/or contact whoever makes that plugin for help resolving the issue it’s causing.

    If deactivating plugins doesn’t help, it may be your theme.

    Temporarily activate a default WordPress theme like Twenty Twenty-One.

    – Then, try the nested comments again. If nested comments works, then you know it’s a problem with the theme.

    You can contact whoever makes the theme for help resolving the issue it’s causing.

    Thread Starter the5krunner


    if i disabled the free version of yoast then indenting works

    Plugin Support Mehdi (a11n)


    Hi @the5krunner

    Thanks for sharing your findings! It seems that there’s a conflict with the Yoast plugin, so I’d suggest reaching out to their support for any solution or workaround to prevent the incorrect behavior.


    Thread Starter the5krunner


    yes this is a yoast bug and they have this workaround:

    Hey @the5krunner,
    Thank you for using Yoast SEO and for reaching out!
    Yoast SEO by default removes ?replytocom variables from URLs (more info about this feature on this link). This can be reversed by adding the following filter to your theme’s functions.php file (or custom plugin):

    add_filter( ‘wpseo_remove_reply_to_com’, ‘__return_false’ );

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘WordPress Comments Not Correctly Nesting’ is closed to new replies.