Support » Fixing WordPress » “wordpress.com stats” pluggin not working

  • I have the following error message on my wp dashboards:
    “WordPress.com Stats needs attention: please enter an API key or disable the plugin.”
    when I click on it it tells me
    “The WordPress.com Stats Plugin is not working because it needs to be linked to a WordPress.com account.”
    It gives me an API key (same as the one in Akismet) but when I save it in the box provided it sys:
    “Your blog was unable to connect to WordPress.com. Please ask your host for help. (transport error – HTTP status code was not 200)”
    My ISP claims to know nothing about wordpress error messages.
    I am on WP 5.7, PHP 7.4, wp.com stats plugin 1.8.5 Windows 10 desktop
    Any suggestions please?

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    Which plugin is “wp stats”?

    Your site does not seem to be working at all. Errors like this are logged. Check the error log on your server. If you can’t find the log, please contact your host.

    Meantime, enable wp_debug and wp_debug_log and after an error, look at wp-content/debug.log to see if anything gets logged there. https://wordpress.org/support/article/debugging-in-wordpress/

    You can also try this: Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you cannot access wp-admin, there are other ways to deactivate plugins.

    Thread Starter crofter

    (@crofter)

    Steven
    Thanks for reply
    By “wp.com stats” I mean the plugin “wordpress.com stats” (Version 1.8.5)
    When I started the thread I had only looked at the dashboard, not tested the site. It turned out that the site was down for an hour or two after I updated from PHP 5.6.40 to 7.4 in the hope that might solve the problem. I have now rolled back to 5.6.40 and the site is up again. Host support is looking at that new PHP problem.
    I would be happy to use the free version of Jetpack instead of the unsupported “wordpress.com stats” plugin which may be related to my original problem but Jetpack doesn’t like me either. When I activate the Jetpack plugin and click on Set Up Jetpack it says
    “Unable to insert blog. Please try again or contact support.”
    I have disabled all other plugins
    I looked at wp_debug but it advises not to use it on live sites. Also if I change to twenty* theme it distorts the busy site (I have been using a very complex theme, no longer supported, for 20 years!) so I’m going to have to try staging. This will take a while.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘“wordpress.com stats” pluggin not working’ is closed to new replies.