Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » WordPress caught an error with one of your plugins, Jetpack by WordPress.com.

  • Resolved wtwp

    (@wtwp)


    Hi,
    As soon as I updated to jetpack 8.3, I received the following error:
    WordPress caught an error with one of your plugins, Jetpack by WordPress.com.
    I deactivated the plugin then my photos especially the feature photos disappear.

    Also, when I changed it to the previous version, it’s the same and I’m unable to click on any button in jetpack.
    When I do, I receive the following errors:
    1. Something went wrong
    2. Error updating settings. FetchNetworkError
    3. 1 file could not be uploaded because an error occurred while uploading.

    I have reactivated the plugin but unable to do anything in setting

    For more info, this is my website composition:
    WordPress version 5.3.2
    Current theme: OptimizePress (version 2.5.18)
    Current plugin: Jetpack by WordPress.com (version 8.3)
    PHP version 7.0.33

    Pls, let me know how to resolve this soonest.

    Thank you.

Viewing 8 replies - 1 through 8 (of 8 total)
  • war59312

    (@war59312)

    I just got this one myself:

    When seeking help with this issue, you may be asked for some of the following information:
    WordPress version 5.3.2
    Current theme: Twenty Sixteen (version 2.0)
    Current plugin: Jetpack by WordPress.com (version 8.3)
    PHP version 7.0.29

    Error Details
    =============
    An error of type E_ERROR was caused in line 270 of the file /home/war59312/public_html/wp-content/plugins/jetpack/vendor/automattic/jetpack-sync/src/Listener.php. Error message: Uncaught Error: Class 'Automattic\Jetpack\Roles' not found in /home/war59312/public_html/wp-content/plugins/jetpack/vendor/automattic/jetpack-sync/src/Listener.php:270
    Stack trace:
    #0 /home/war59312/public_html/wp-content/plugins/jetpack/vendor/automattic/jetpack-sync/src/Listener.php(239): Automattic\Jetpack\Sync\Listener->get_actor('jetpack_plugins...', Array)
    #1 /home/war59312/public_html/wp-content/plugins/jetpack/vendor/automattic/jetpack-sync/src/Listener.php(114): Automattic\Jetpack\Sync\Listener->enqueue_action('jetpack_plugins...', Array, Object(Automattic\Jetpack\Sync\Queue))
    #2 /home/war59312/public_html/wp-includes/class-wp-hook.php(288): Automattic\Jetpack\Sync\Listener->action_handler(Array, Array)
    #3 /home/war59312/public_html/wp-includes/class-wp-hook.php(312): WP_Hook->apply_filters('', Array)
    #4 /home/war59312/public_html/wp-includes/plugin.php(478): WP_Hook->do_action(Array)
    #5 /home/war59312/public_html/wp-content/plugins/jetpack/vendor/automattic/jetpack-sync/src/modules/Plugins.php(168):
    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    Are you able to update to PHP 7.3 or higher? If so, does the issue continue?

    Hi,

    I’ve updated to PHP 7.3, the highest I can update to and I’m still getting :

    Error updating settings. FetchNetworkError

    Thanks

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    Ok, what is the URL of the site with the problem, and specifically which version of PHP 7.3 are you on now?

    Hi,

    This is the website link, I have changed over no PHP 7.2 because PHP 7.3 caused an issue in some pages.
    I’m only using jetpack because of the stats, and I will gladly delete it when this issue is resolved.
    unfortunately, when I disabled it, my photos disappeared.

    Currently, I can’t do any new post or attach any new image; I have been trying this for 2 weeks now, so any speedy help will be highly appreciated.
    Thanks 🙂

    Plugin Support fresatomica

    (@fresatomica)

    Thanks for the link.
    It looks like there’s a problem with the XML RPC endpoint on your site.
    Problems accessing XML RPC could be due to another plugin, a security module, or a block on your server. As a first step to fixing this, I’d recommend contacting your host to see whether they block XML RPC and if so, to unblock it for Jetpack (they can find our IP range here https://jetpack.com/support/hosting-faq/).
    Let us know what you hear back from your host, and we’ll retest the Jetpack connection once ready.

    Hi,
    Thank you.
    I have checked with the host and it has nothing to do with the server.
    They didn’t block XML RPC.
    But I’ve always had the other plugins installed with no issues at all. is it because of the update to 8.3? Because that’s when the issue occurred.

    Even after deleting it completely, the images are not showing. I have re-installed and it’s still the same.
    It’s a shame this is happening because I have a lot to do on the website and I’ve already lost 2 weeks.
    Maybe uploading a previous backup file could do the magic?

    Plugin Support fresatomica

    (@fresatomica)

    Hmm, I’ve been digging a little and it all sounds as if something was affecting Jetpack but also other features on your site – the disappearance of the featured images is likely not related to Jetpack.
    Since your site is hosted on Cloudflare, it might be good to follow these steps:

    https://jetpack.com/support/getting-started-with-jetpack/configure-jetpack-cloudflare/

    Let us know once this is done, we’ll check if this helps with the connection.
    After that, I’d suggest ruling out plugin conflicts so disabling all plugins except Jetpack and enabling them one by one, refreshing the site after each to see if the featured images disappear again.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WordPress caught an error with one of your plugins, Jetpack by WordPress.com.’ is closed to new replies.