WordPress Can't Edit Any Files Or Directories (3 posts)

  1. joamette
    Posted 4 years ago #

    In my search through the troubleshooting forum, I came by lots of entries about WordPress refusing to edit specific sorts of files or directories; however, the problem I'm having is that WordPress can't seem to edit anything at all. My WordPress installation, in essence, is unable to manage content.


    Whenever I try to update to the latest version of/install any plugins or themes, I get this message:

    An error occured while updating Akismet: Download failed. Could not create Temporary file..

    When I try to edit files from within WordPress, such as the comicpress-config.php file, I get messages like this:

    Configuration not updated, check the permissions of /wp-content/themes/comicpress/comicpress-config.php and the theme folder. They should be writable by the Webserver process.

    I receive a similar message when I attempt to upload an actual comics file.

    I want to know what could be causing this in addition to how to fix it. I don't want to simply edit and upload things manually (what would be the point of WP then?), and I don't want to chmod 777 all my files and folders (which doesn't seem to be working either anyway - I tried it on select directories).

    This is the site I'm working with, which has literally nothing on it (it's a fresh install): http://www.kollapsar.com/. My webhost is http://www.lowesthosting.com/ and I'm using the web-based FTP client provided by the host. My skill/knowledge level when it comes to websites is "figure it out as you go along," so I'd love any answers to be written "for dummies" style.

    Thank you so much for any help you can offer!

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Change the permissions on the wp-content directory to 766. If you still have problems, try 767 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.

  3. joamette
    Posted 4 years ago #

    I tried that. It doesn't work.

Topic Closed

This topic has been closed to new replies.

About this Topic