WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] WordPress Built-In Cache

[Resolved] WordPress Built-In Cache

  • Hi,

    Although I enabled the WordPress built-in cache, the number of mysql query stay the same. Isn’t it supposed to decrease if it is enabled?

    I placed this in the wp-config.php

    define(‘ENABLE_CACHE’, true);
    define(‘CACHE_EXPIRATION_TIME’, 180);

    In the footer.php, I put the following code.

    global $wpdb;
    timer_stop(1);
    echo “seconds with” . $wpdb->num_queries . “database queries”;

    Any information would be greatly appreciated.

Viewing 4 replies - 1 through 4 (of 4 total)
  • I haven’t really dealt with the “built-in” cache for WordPress *yet*.. but, you could maybe go through the threads over here once, maybe? Or, maybe one of the threads from this search result will help.. Good luck!

    spencerp

    Thanks, I apprecite your information.

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    Isn’t it supposed to decrease if it is enabled?

    It *can*. That doesn’t necessarily mean that it *will*.

    Also, looking at the 2.05 code, it seems like it only works when PHP’s safe_mode is turned on. Which is contrary to what the comment right there in the code happens to say. I’m guessing that it is not bug-free at this point, and it’s probably best to leave it off for now.

    I see. Ok then I’ll give it up and go with the WP-cache. Thanks Otto.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] WordPress Built-In Cache’ is closed to new replies.