Support » Fixing WordPress » WordPress Bug? Unable to update or add new page/post to site

  • Hi, never had this problem before. Today when I tried to update an existing page I was redirected to the homepage of my website, instead of the usual WP page containing the success/error message. The update isn’t published. Tried to add a new post and got the same.

    Deactivated all plugins and still the same – cannot update or add new post/page. Always redirect to the home page when trying to publish.

    WP 2.7.1 Site http://www.propertyinkrabi.com Hosted by Micfo.

Viewing 3 replies - 1 through 3 (of 3 total)
  • i started noticing this, too, using 2.6.3 – so i updated to 2.7.1, and it’s still doing it.

    i thought maybe my host had changed something in .htaccess or PHP settings, but i can’t see any errors or warnings in the logs, and i even took out the .htaccess temporarily. still nothing.

    i’ve also tried reapplying 755 permissions to everything, deactivating all my plugins, and removing and reinstalling 2.7.1 – still broken.

    odd… i thought the site was being hosted at Network Solutions, but doing a lookup on the domain, it’s coming back as a Micfo address as well.

    maybe Micfo broke something on their end?

    based on one of several other posts along these lines, i was able to fix the problem. it’s related to mod_security, and, at least on my server, the fix was to add this to a .htaccess file inside the wp-admin directory:

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘WordPress Bug? Unable to update or add new page/post to site’ is closed to new replies.