WordPress.org

Forums

WordPress Bug- Admin are problems in Opera (5 posts)

  1. vyperlook
    Member
    Posted 3 years ago #

    It seems that wordpress has serious problems on admin area in Opera browser (since updated to 3.2). nothing works there,i can only write in html ,the editor is not working there . it's also adding some strange code...can someone check this please ?

    thanks

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    The dashboard is fine for me using Opera 11.50. Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

  3. David Anderson
    Member
    Posted 3 years ago #

    I have the same problem. I was using Opera 11.11. I have tried on 3 different sites, twice in WordPress 3.2 and once in WordPress 3.2.1. I upgraded to Opera 11.50 and the problem remains. Visual editor stops working. This is using Opera on 64-bit Linux.

    Here is a Javascript Exception from Opera's log after a copy-paste operation; after this exception, all visual editor operations stopped working.

    [16/07/11 11:52:58] JavaScript - http://localhost/ic/wp-admin/post-new.php?post_type=page
    Timeout thread: delay 4 ms
    Uncaught exception: DOMException: INDEX_SIZE_ERR
    Error thrown at line 2, column 172088 in <anonymous function: setRng>(i) in http://localhost/ic/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=342-20110630:
    g.selectedRange=h.getRangeAt(0)
    called from line 2, column 160437 in <anonymous function: setContent>(k, j) in http://localhost/ic/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=342-20110630:
    h.setRng(f)
    called from line 2, column 319323 in <anonymous function: mceInsertContent>(z, D, E) in http://localhost/ic/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=342-20110630:
    p.setContent('<span id="__mce">\uFEFF</span>',{no_events:false});
    called from line 2, column 314080 in q(y, x, v) in http://localhost/ic/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=342-20110630:
    u(y,x,v);
    called from line 2, column 291213 in <anonymous function: execCommand>(x, v, z, p) in http://localhost/ic/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=342-20110630:
    if(r.editorCommands.execCommand(x,v,z))
    called from line 14, column 22682 in <anonymous function: _insert>(f, d) in http://localhost/ic/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=342-20110630:
    e.execCommand("mceInsertContent",false,f,{skip_undo:d})
    called from line 14, column 3192 in h(m, k) in http://localhost/ic/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=342-20110630:
    f._insert(m.content)
    called from line 14, column 8091 in <anonymous function: init>() in http://localhost/ic/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=342-20110630:
    h({content:u});

  4. traffas
    Member
    Posted 3 years ago #

    I'm having serious Opera problems as well since upgrading. These problems happen on multiple sites on multiple web hosts on multiple themes and plugin configurations. What can we do to help fix this problem?

  5. XP1
    Member
    Posted 3 years ago #

    Recently, I have discovered (and fixed) a bug in TinyMCE, which Livefyre uses and also has the bug.
    For the "getRangeAt, INDEX_SIZE_ERR" JavaScript error, have a look at my blog post.

    TinyMCE JavaScript error in Opera (getRangeAt, INDEX_SIZE_ERR):
    http://my.opera.com/XP1/blog/2011/07/21/tinymce-javascript-error-in-opera-getrangeat-index-size-err

    See my pull request here:
    https://github.com/tinymce/tinymce/pull/77/

    Let me know if testing reveals that it works or doesn't work.

    This TinyMCE bug was previously reported from at least 2011-04-14, yet has not been fixed (until now, hopefully). See TinyMCE bug reports #4306 and #4372 (duplicate).

    This one JavaScript error is what seems to be causing all types of problems, including the CTRL + V paste bug and the underscore bug. I fixed the bug and submitted a pull request (see above).

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags