Support » Fixing WordPress » WordPress broken?

  • My WordPress blog was working perfectly until today when I tired to add a new post and it wouldn’t let me. Sometimes it let me save the post, but usually it just kicked me out of the admin section and went straight to the homepage. So when I had saved a post I tried to delete it would go back to the Manage Posts section with that particular post flagged in red but not deleted.

    It looks like I can’t add or edit (it kicks me out of the admin but I’m still logged in), or delete. but strangely I can delete the post from the edit page.

    I upgraded to WordPress 2.2 and the same is still happening. I have administrator provileges, and the same happens when I log in as admin.

    I have even deleted all the files from the server and reuploaded it all (except for the theme). I jhave deactivated and deleted all plugins and still the same.

    The database seems OK. I’m not technically minded, but there doesnt seem to be anything different on cpanel or myPHPadmin. I dont know what I’d be looking for anyway, but i’ve even gone on to Check DB and Repair DB and everything seems to be OK.

    I just don’t know what else to do. Please someone, help!

Viewing 2 replies - 1 through 2 (of 2 total)
  • looks like you run into an error a lot of other users experienced.
    I have experienced the same, trying to delete a post, it turns red but doesn’t get deleted.

    Macbrink thank you sooooooooo much for pointing me to that thread. I did the following as suggested:

    Created a new .htaccess file and placed it inside the wp-admin folder

    Placed the following code inside the .htacess file

    <IfModule mod_security.c>
    SecFilterInheritance Off

    I don’t know or understand what it does or what was wrong but the main thing is that everything is back to normal 🙂

    Thanks again 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘WordPress broken?’ is closed to new replies.