[resolved] WordPress broke. (5 posts)

  1. shogem
    Posted 5 years ago #

    I have several issues now.

    First off, I was attempting to fix my galleries. My website galleries were in 4 and 5 column rows respectively, and after checking them recently, I realized they only worked in one column formats, no matter what I did to change them. I deactivated my Cleaner Gallery Widget, only to discover that completely removed the galleries' visibility.

    I went down into my media settings and looked over the options (which I didn't touch), and saved them. Now, my website looks like this, with each post being unviewable (and ironically the comments are viewable). The galleries are also still broken. I assure you that content is there, but this problem is now completely over my head.

    While I'm at it, does anyone know why my tumblr widget isn't working? It seems to work with other blogs running 3.0.3.


    Any help is appreciated.

  2. Tara
    Volunteer Moderator
    Posted 5 years ago #

    Try (if you already have not tried):

    -deactivating ALL plugins temporarily to narrow down and possibly fix the problem. If the problem goes away, activate them individually to find the culprit.

    -switching to the default theme ("twentyten") for a moment by renaming your current theme's folder in wp-content/themes. The idea is to force WordPress to fall back to the default theme to rule out any theme-specific issue.

  3. shogem
    Posted 5 years ago #

    Alright. Step one yielded this result on every post and every page:

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'gallery_columns' was given in /home/wings/public_html/wp-includes/plugin.php on line 166

    Checking line 166 gave me this:

    do {
    		foreach( (array) current($wp_filter[$tag]) as $the_ )
    			if ( !is_null($the_['function']) ){
    				$args[1] = $value;
    				$value = call_user_func_array($the_['function'], array_slice($args, 1, (int) $the_['accepted_args']));

    (Dreamweaver lists line 166 as $value = call_user_func etc etc)

    So it's something server side I don't understand. Should I proceed with your suggestion of turning each back on until I find the culprit, or has it just revealed itself? For reference, I have the Gallery Widget plugin as well (but that seemed to be working). I'm thinking it may be the problem, but I'm probably wrong.

  4. Tara
    Volunteer Moderator
    Posted 5 years ago #

    looks like deactivating all plugins did not resolve the issue.

    - try resetting the plugins folder by FTP or phpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems (because the hooks remain unless plugins completly removed).

  5. shogem
    Posted 5 years ago #

    I tried both methods. No change. And, using phpMyAdmin, the value was already listed as a:0:{}. Is it super broken?

Topic Closed

This topic has been closed to new replies.

About this Topic