Support » Plugin: WordPress Beta Tester » WordPress Beta Tester plugin configuration will downgrade your install…

  • Resolved Mason Verger

    (@deplancy)


    Please can you advise how to resolve this issue that I’m getting using your plugin in the last few days.

    When logged in we see a notification “Your current WordPress Beta Tester plugin configuration will downgrade your install to a previous version – please reconfigure it.”

    Now, I’m receiving an alert email from Wordfence with the info:
    =======================================================
    Alert generated at Saturday 25th of April 2020 at 10:28:54 PM

    High Severity Problems:

    * Your WordPress version is out of date
    =======================================================

    We are using the ‘Point release nightlies’ option in your plugin.

    Thanks greatly, best wishes

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Andy Fragen

    (@afragen)

    It’s just a warning. It happens because you were likely on trunk and switched to point releases to test. It’s usually nothing to worry about and the only real issue is if there was a database update that’s not backwards compatible.

    “It happens because you were likely on trunk and switched to point releases to test.” = Nope we didn’t do that, I haven’t touched the config settings.

    Why is Wordfence telling me the following then (?) ” High Severity Problems:

    * Your WordPress version is out of date”

    Not meaning to be truculent here; it’s just it gives rise to concern. I’ve been using your plugin for some years and have never had any issues of this nature before.

    Thanks for your time. Best wishes

    Plugin Author Andy Fragen

    (@afragen)

    Can you tell me the current version of WordPress and what it says you will update to in the Beta Tester Settings page?

    *WP dashboard says: development version (5.4).
    ========================
    *In Beta Testing settings:

    ” Point release nightlies This contains the work that is occurring on a branch in preparation for a x.x.x point release. This should also be fairly stable but will be available before the branch is ready for release.”
    ========================

    *At the top of both pages it reads (notification):

    WordPress 5.4 is available! Please update now.
    ========================
    *On the Main Updates page it reads (notification):

    “Warning: Your current WordPress Beta Tester plugin configuration will downgrade your install to a previous version – please reconfigure it.”

    Also on the WordPress Updates page we have:

    WordPress Updates

    Warning: Your current WordPress Beta Tester plugin configuration will downgrade your install to a previous version – please reconfigure it.

    Last checked on 26 April 2020 at 8:23 am. Check Again

    You can update to WordPress 5.4–en_GB automatically:

    You can update to WordPress 5.4–en_US automatically:

    =========

    Seems odd we get this message: “WordPress 5.4 is available! Please update now.” as we have already updated to 5.4.

    What to do with this issue?

    Kind regards, AE

    Plugin Author Andy Fragen

    (@afragen)

    Thanks. You’ve given me something to test.

    If you aren’t actively testing WordPress Core then you probably should deactivate the Beta Tester plugin as this is the sole purpose of this plugin.

    “If you aren’t actively testing WordPress Core then you probably should deactivate the Beta Tester plugin as this is the sole purpose of this plugin.”

    = Ok, maybe I will just go that route. Let me know if there’s any precautions I need to take when deactivating the plugin, and reverting to standard WP core updates though.

    best wishes

    Plugin Author Andy Fragen

    (@afragen)

    There should be no issues deactivating the plugin.

    Ok. Thanks for all your help Andy.

    Plugin Author Andy Fragen

    (@afragen)

    @deplancy I think I have this fixed in the develop branch. I’ll release as soon as I’ve finished testing.

    Ok, great. Post here again when it’s fixed. Have used your plugin for years and will do again in that case.

    Plugin Author Andy Fragen

    (@afragen)

    Plugin Author Andy Fragen

    (@afragen)

    @deplancy these updates are in v2.2.10

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.