[resolved] WordPress auto-install and upgrade (73 posts)

  1. wenu
    Posted 6 years ago #

    Why is it that some Hosts DON'T have Auto Install and Upgrade.

    Who can give a guide on what needs to happen for a Host Server to permit Auto-updates?

    It seems more related to the Host Server than to the Domain Access rights, but who can give a straight answer??


  2. James Huff
    Support Representative
    Posted 6 years ago #

    Automatic installations are something that's usually developed by the hosting provider in-house, or they purchase an annual or monthly license to a service like Fantastico.

    Automatic upgrades, on the other hand, are done through the WordPress admin panel and should be available under most hosting providers.

  3. mrmist
    Forum Janitor
    Posted 6 years ago #

    http://codex.wordpress.org/Core_Update_Host_Compatibility is a list of hosts that have been tried by users and confirmed to have worked with the automatic update.

  4. wenu
    Posted 6 years ago #

    mrmist - Many Thanks

    My Host isn't listed at all, although they (anonymous) are giving themselves to be substantial players.

    For the record, my Host doesn't claim to be an authority on WP or DirectAdmin but says the matter of "permission", which is the hassle with Auto-Updates, should be fixable via a risky setting.
    He says putting the Plugin Folder and the individual plugin folder permissions at 777 will make it work (it doesn't) but that doing so would leave the Blog susceptible to hacks. I can accept it would create a susceptibility.

    My Host does use latest Unix and PHP so that would not be the hassle. I suspect there is some form of "identity' crisis, whereby my User identity - Admin identity clash somehow. You know Admin is associated with WP at Setup. Users (Blog Contributors) can have Admin rights throughout WP Dashboard but are distinct from the WP Admin Name and Password and are also distinct from the DirectAdmin Username and Password.

    I tried creating an Admin in WP Dashboard with the same Username and Password and it had no effect about a year ago. It wasn't critical then because Plugin Manager showed which plugins had updates available. I just Downloaded the zip and used FTP to Install and Dashboard to Activate.
    Now Plugin Manager doesn't show which ones have updates available (realise, most of the time NONE have updates available but now and then one or even sometimes two on the same day can provide updates) so the only alternative is to hunt through home pages of plugin developers, looking for Version data to compare with what is listed next to the plugin in the Plugin Manager. A drag!

    This problem is only in WP 3.0 RC1; RC3 and WP 3.0

    I have reverted to 2.9.2 during testing with RC1 and RC3 so I know the hassle is only within the Plugin Manager architecture of WP 3

    I sense the reasoning was 'someone' decide that this feature was no longer required in light of Auto-Update and Multi-Site facilities.

    WRONG - those of us still just using WP for a Blog don't need MS but DO like to know WHICH Plugins have updates.

    Until WP fix it we will continue to publicly pillory them at http://www.wenublog.com and on Twitter and anywhere else we get the opportunity.

  5. maoski
    Posted 6 years ago #

    wow, what a dag, it looks like all updates now sit under the menu item {Dashboard > Updates} for wordpress version, plugins and themes. Are u saying you cannot see this, i updated all my plugins all at the same time there.

  6. mrmist
    Forum Janitor
    Posted 6 years ago #

    Yep, there's definitely still notification for out of date plugins.

  7. James Huff
    Support Representative
    Posted 6 years ago #

    Ouch, I'm sorry that you have been so offended by the latest release of this volunteer-built and volunteer-supported free blogging platform.

    As maoski mentioned, do you not see the new all-in-one automatic update system at Dashboard/Updates in your admin panel?

  8. mrmist
    Forum Janitor
    Posted 6 years ago #

    The availability of auto-update would depend on the security settings for your blog, however, if you've been previously able to update plugins you should still be able to do that now.

    In fact, you should still see the "update available" numbers next to both "Plugins" and "Update" (under Dashboard). If not, please can you provide details of what does appear in your "Plugins" section.

  9. wenu
    Posted 6 years ago #

    Look. I'll go and 'revert' a Plugin. I have earlier versions still on my harddrive.
    I'll Activate a superceded version in the Plugin Manager and see if it tells me the status - meaning, that a newer version is available for that plugin.
    What has been happening in the past is simply that the Plugin Status indicated on the Dashboard PAGE is that it says (for instance one (1) plugin update is available) but not WHICH Plugin - and yes, as indicated, Automatic Updates doesn't work on these Shared Hosting arrangements so people like us need to use Manual methods.
    Manual for us is not a problem because - get this - we only have one Blog to update, not the much vaunted "tens of thousands." MS means nothing to us.
    Scrambling all over the Plugin Manager, clicking on "visit plugin site" to compare the installed version with the Developer site version [IS A BUG] "K! WE HAVE A BUG!"
    Or not. For at least the second time I wil go and revert a Plugin and verify the fault persists. We are nice here.
    It is, after all, Angel Central.

  10. James Huff
    Support Representative
    Posted 6 years ago #

    Sorry you're having trouble with this.

    I can't offer much more than the fact that available plugin updates are indicated and identified in both the Updates and Plugins sections of the admin panel on several of the blogs that I manage (all on shared hosting with different providers, BTW).

    On your blog post, Jacob Black mentioned bumping PHP's memory allocation, which you might want to try. Here are five ways to increase PHP's memory allocation:

    1. Try the Memory Bump plugin:
    2. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)
    3. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M
    4. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define('WP_MEMORY_LIMIT', '64M');
    5. Talk to your host.

    If that doesn't work, maybe it's time to switch to a new hosting provider (especially one that works with the automated updates feature)?

  11. mrmist
    Forum Janitor
    Posted 6 years ago #

    Both the Dashboard - Updates screen and the Plugins - Plugins screen should show which plugins require updating.

    Can you post some screenshots of what you are seeing?

  12. wenu
    Posted 6 years ago #

    Thank You for the specific suggestions. It may shortly come to that.
    SITREP on the action I took as promised:
    The Plugin I chose was WPtouch - I reverted it to version. 1.9.12
    On return to Dashboard the Plugin was still Deactivated so nothing showed.
    Activated the Plugin without hassles - following displays:
    Dashboard showed usual Dropdown:
    Updates (with a black square behind a white 1) was RED in WP 2.9.2
    Exploit Scanner
    Site Stats
    Akismet Stats

    Further down the page was of course Plugins (with same B/W indicator of One Plugin update available.

    Clicked on Plugins (which was also BOLD btw) and Plugin Manager came up, showing the list of Plugins installed, including WPtouch with the version number 1.9.12 - AND NO INDICATION THAT THIS WAS THE PLUGIN WITH THE UPDATE AVAILABLE (not shouting - just drawing attention)

    Now I know WPtouch is the plugin with update 1.9.13 available but it's the last one on the list and to find it I would have to click on "Visit plugin site" of every plugin before I would find that 1.9.13 is available and I only have 1.9.12 installed.
    That's a bug.

    I shall now explore my options as suggested above. Not sure where PHP.ini is but I can check the others in DirectAdmin
    There is also a suggestion I may play with, from an Italian here in the forum, which suggested adding:
    to WP-config.php

    I think you clearly see the small defect I am upset about, simply because there must be many out there with this problem - but they may not even be aware of it yet, depending on what Plugins they use and whether any updates have been posted for THEM since they installed WP 3.0 We tested with RC1 and RC3 and bleated about this for weeks now with no real result until today's final umbrage.

    BB2 (or longer as the case may be)

  13. wenu
    Posted 6 years ago #

    I have no access to PHP.ini (could not find it and PHPMyadmin says "no rights" ) [shared hosting I would expect]
    Updated wp-config.php to include:
    define('WP_MEMORY_LIMIT', '64M');

    Had no effect whatsoever - didn't even crash the blog :)

    As that did nothing I will revert to the previous WP-Config.php
    and update WPtouch back to its 1.9.13 state.

    I consider this "not resolved"

    mrmist says:
    "Both the Dashboard - Updates screen and the Plugins - Plugins screen should show which plugins require updating."
    The Dashboard Updates in the past only said HOW MANY were avilable, (such as (1) or (2)) not which ones.
    The Plugin Manager ALWAYS showed the update VERSION available if one was.
    I think this is a simple thing for WP Developers to fix but it seems like it was something overlooked in the haste to incorporate MU into WP and to 'box in' Auto-Update as if it was universally applicable.

    It's not.
    I'll watch traffic and see how Guran goes with this over the next week or so. I expect it will be fixed.

  14. wenu
    Posted 6 years ago #

    I have the con.
    All plugins are back at current version.
    WP 3.0 is running perfectly.
    No Plugin updates are indicated as available.

  15. esmi
    Forum Moderator
    Posted 6 years ago #

    Can I ask how long you waited for a known plugin update notice to appear? WP only phones home once or twice a day, so if you just "missed" the last call, it could take up to 24 hours before there's another. If this is to be submitted as an issue, I think it would be sensible to rule out any time factor first.

  16. mrmist
    Forum Janitor
    Posted 6 years ago #

    OK there's something not clear here, because you're not seeing what you should.

    This -


    Is what you should be seeing. The plugin available to be updated is clearly shown (it's expertly highlighted by myself in the jpg.)

    Please post a jpg of what you're seeing, and tell us in which browser.

    Also, which plugins are you running?

    ETA: The functionality to see which plugins have updates waiting from within the screen called "plugins" has not changed in 3.0, you can still see them listed there.

  17. If your plugin update notifications aren't showing up, then there's two possible reasons.

    Reason 1: Your server cannot contact api.wordpress.org in order to check for updates. This is the case on many servers that don't allow arbitrary outside connections.

    Reason 2: You are trying it too often or expecting too quick of a response. Plugin update checks only happen once every 12 hours, tops. Even if you change the version number, you'll have to wait for your WordPress installation to check for updates again before it notices.

    Note: Permissions have nothing whatsoever to do with this. The update checks and actually performing the updates themselves are two entirely separate things.

  18. wenu
    Posted 6 years ago #

    That was a nice image mrmist
    Sadly, it seems to refer to an update for WordPress itself, rather than an update for a plugin. I say that because the advice seems to note "Comment Timeout" and has a 1 next to "Comments" - so I am assuming that was NOT a plugin named Comment Timeout. Forgive me if I'm wrong. ut! I suspect I AM wrong! You have a Plugin Called 'Comment Timeout' right?
    Then there is the problem associated with the entire 'view'.
    If I click WordPress 'Updates' I get a scaly little message saying I am unclean ie. "no permission' and I see NONE of your gracefully scripted window of auto and manual options, complete with version details etc.
    We do not see an Update Advice Note coming up as a "Comments 1" either!
    We only see the (1) next to Dashboard Updates, and farther down, next to Plugins.

    What WE do is go farther down the Dashboard to the Plugins section and click on that, to see ALL our plugins and a note somewhat similar to the one in your image, telling us an update is available for a specific Plugin, which update and a link to the Plugin Site.

    With this "wonderful one click" upgrade of WordPress, the Designers and Developers have removed a very simple facility that saved Bloggers in our position from having to manually, one by one, search the plugin site of every plugin, comparing the available version with the version installed so as to discover WHICH plugin has been updated.

    We like that those who can use Auto-Update have this wonderful facility your image illustrates but we wish you had not removed the main functionality (for us) of the Plugin Manager. It used to be cool to pop in there and see which plugin had been updated.

    "you do not have sufficient permissions to update plugins"
    Code is Poetry - or Blank Verse, as the case may be.

  19. wenu
    Posted 6 years ago #

    Oh! And the reason we are discussing Plugins in the Auto-Update thread is because, due to the way this Forum operates, nobody was ineterested anywhere else, during the last couple of weeks. (since RC1)
    Thank you all, for commenting here.
    Poetry is Code, if you see what I mean.

  20. wenu
    Posted 6 years ago #

    For the record, I created a new User in the Dashboard, identical to the API registration, which anyway was correct, and find when I log in the situation remains the same. The new User has Admin rights in the WP Dashboard and we are really dealing with WordPress functionality, as someone pointed out, rather than DirectAdmin functionality.

    My Host has never indicated that he sees his Server as related to this problem within the WP Dashboard and the associated plugins - although Plugins might be a misnomer as WordPress Automated Updates probably is still dead.

    In anycase, when I click on Updates I still get the message about not having permission to update plugins. That seems to be a generic screen which I have also seen when attempting WP Auto-updates, not just Plugins.

    We chatted about it here and find it hard to believe nobody else 'in the World' has this problem or a solution to it. One man in a thread that seems to have disappeared said, "Ditto" but nobody else commented in that forum thread so we have stuck with this one which at least seems responsive. No solutions dropped out though, yet.

  21. wenu
    Posted 6 years ago #

    I think I got this syntax right. Cut and paste is:
    You do not have sufficient permissions to update plugins for this site.

    Regardless of Firefox or IE - all same same.
    I Deactivated ALL plugins and same response on clicking Updates.
    Not the end of the world. We were just discussing options here.
    Not as if we sit back and do nothing - but nothing changes the situation.

  22. James Huff
    Support Representative
    Posted 6 years ago #

    You do not have sufficient permissions to update plugins for this site.

    A couple of thoughts:

    1. Unfortunately, it could be your hosting provider. Due to various server configurations, some restrict this functionality. I have had the privilege of utilizing several shared hosting providers who do not, but also the displeasure of suffering through a few that do. A switch may be in order.

    2. Try changing the permissions of /wp-content/ , /wp-content/plugins/ , and /wp-content/upgrade/ to 777.

    3. Maybe your account lost full admin privileges? Access your database via phpMyAdmin (most hosting providers offer this in their control panel), go to the wp_users table and find the row for your user_login . Note the ID of this row. Now, go to the wp_usermeta table and find the wp_capabilities row for your user_id . Set the value of this row to a:1:{s:13:"administrator";b:1;}

    Remember that WordPress only checks for plugin updates once every 12 hours, so if you don't see any updates readily available, wait at least 12 hours.

    As mentioned earlier, many of us see the plugins in need of updates identified clearly both in the Updates section (mrmist's screenshot) and the Plugins section (I'll take one the next time I see one available).

    In the case of mrmist's screenshot, the plugin "Comment Timeout" is clearly identified as being available for updating, followed by "You have version 2.0.1 installed. Update to 2.1.1." As you can see, this both identifies the plugin to be updated and the version that it is to be updated too. I can assure you that the update notification in the Plugins section works no different than it did under 2.9.2.

    Believe me, I wish that I could offer more than "It works for me," screenshots for proof, and the occasional "Maybe try this" response, but that's all that I have to offer. Because this functionality does work for me, exactly as it did under 2.9.2 (with the addition of the all-in-one Updates section), it's hard to speculate as to what is causing your particular problem.

  23. mrmist
    Forum Janitor
    Posted 6 years ago #

    Indeed the plugin "comment timeout" was being shown as requiring an update. I cut that section from the Updates part of the screen, but you still (are supposed to) get the exact same message in the Plugins screen, just as always.

    I suspect point (3) in the post above might be an important one in this case, there's not many other reasons why your admin login would get a WordPress permissions error (as apposed to a server permissions error.)

    The code (in update.php) that controls this message is

    if ( 'update-selected' == $action ) {
    		if ( ! current_user_can( 'update_plugins' ) )
    			wp_die( __( 'You do not have sufficient permissions to update plugins for this site.' ) )

    Which suggests that your admin user has lost that right from his role, which in turn suggests that at some point you've used a role-manager type plugin which has somehow screwed with your WP rights. Have you used any such plugins? It should be fixable with macmanx's point(3) above, but it depends on the severity of the damage.

  24. wenu
    Posted 6 years ago #

    Ahh! these are hot points.
    I'll send Rinty and the 7th to investigate those exact suggestions.
    Many thanks, guys.
    I will return and report.

  25. wenu
    Posted 6 years ago #


    PhpAdmin shows all my admin Permissions are fine - which is just as they are under Users in the Dashboard.

    I fiddled with the Folder permissions in the Domain, as I have in the past (this was also suggested by my Host) but that has no impact on the 'permissions' message above.
    True, there is no wp or plugin update available right now but I would expect the Screen to come up, despite there being no updates to display.

    I'll try that again next time an update does show up but I have no real expectations of success.

    About a year ago I dropped this in my Host's lap and got no real response aside from that, if I chose, he could update WP for me. That was unsatisfactory because I can do it myself anyway (we all can here) but it would help if he would withdraw the cork he has inserted somewhere which interrupts the flow. That's a solution that works well with good wine but I'm not up on Servers and I think I have in mind a different kind of Host!

    I'll email him the url for this thread. He will prolly go out in sympathy with you guys! lol


  26. James Huff
    Support Representative
    Posted 6 years ago #

    This may very well be the solution that you've been looking for:


  27. wenu
    Posted 6 years ago #

    I tried all that Macmanx and had no success.
    (actually thought I reported back here too but my post is gone)

    My Host says this problem has only affected selected clients from time to time so it's not his Server. He seconded the suggestions in this thread and actually went in and verified I had all my internal settings correct.

    While 'looking' at WP Settings I altered the url and crashed the Site. Have reverted to a Restore point on 18th June so the Angel has taken the Blog Post about WordPress 3.0 !!!!! "The Angel giveth and the Angel taketh away!"

    I plan to look at it sometime today, as I get time.
    Following options are to:
    1 Delete all unnecessary parts of WP - keeping the Theme and certain files like wp-config etc which I will need to identify yet;
    2 Reinstall WP 3.0 and see if there were any un-deleted files/folders from a previous installation causing a hangup in there.
    3 If that fails (and it will require some time to do all that - takes 35 minutes to FTP WP from my HD to the Domain), then I will revert the site to WP 2.9.2 and gerrymander /includes/version.php just so the Dashboard doesn't keep shouting at me there is a new version. (I did this in the past, for similar reasons, and can still test subsequent upgrades as they are released).
    Anyway, the Post on the Blog is down, along with all the interesting comments, including some of our own!!!
    We consider this defect still not-resolved.

  28. James Huff
    Support Representative
    Posted 6 years ago #

    I would certainly try the re-install route next. Make sure that you backup everything beforehand and let us know how it goes.

  29. talentsfromind
    Posted 6 years ago #

    If you've been previously able to update plugins you should still be able to do that now.The availability of auto-update would depend on the security settings for your blog.In fact, you should still see the "update available" numbers next to both "Plugins" and "Update" (under Dashboard).

  30. wenu
    Posted 6 years ago #

    Was never able to Auto-Update in WordPress. Was used to doing so in Joomla and felt peeved it didn't work here.
    Before I found a good FTP platform I had to upload all the folders and files discretely using DirectAdmin - took two and a half hours!
    Today I did delete completely the admin and includes folders and all the public files except Config. I downloaded the original files (files) from the public-html directory and ended up replacing the two Sitemap files associated with Google XML Sitemap.

    With a completely new instal of WP and NO plugins activated, I still had "You do not have sufficient permissions to dada plugins".

    So now I am letting this run for a day. I have all the plugins (only 11 now) running as planned and I'll wait to see if anything promulgates in the next day to change things.

    In another thread I put in a FIX for fatal error with WordPress Stats. My FTP uploaded wp-includes/class-IXR.php with the ixr in lower case! That is something that needs to be watched.
    I'll have to check my FTP (FTP Clasic by NCH) and see if it's set to convert all filenames to lowercase.
    I am still stonkered on autoupdates though.
    By Friday I will probably revert to 2.9.2 and slip the includes/versions file for 3.0 in to shut up the Updates Alert.

    Over - and out to watch World Cup in 10 minutes at 4 am. Australia are playing someone. Serbia?


Topic Closed

This topic has been closed to new replies.

About this Topic