Support » Everything else WordPress » wordpress and some fastcgi problems

  • Today I noticed that I cannot save any posts on one of the wordpress installs I run on my server.
    I did a couple of tests and found out: I can save pages and “simple” posts. Simple as in not many categories and taxonomies involved. tested a few wordpress isntalls, and the new ones, could save posts just fine, the more elaborate ones, i.e. can’t. The saving simply times out in the browser.

    Checked my server logs and found this: - - [22/Mar/2012:14:46:34 +0100] "POST /wp-admin/post.php HTTP/1.1" 500 829 "" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_3) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.109 Safari/535.19"

    which seems to be a server 500 error and

    (70007)The timeout specified has expired: mod_fcgid: can't get data from http client
    this seems to be a fast_CGI timeout error but which value to raise?

    found these possible ones:

    <tmpl_if name='fastcgi_config_syntax' op='==' value='2'>
            FcgidIdleTimeout 300
            FcgidProcessLifeTime 3600
            # FcgidMaxProcesses 1000
            FcgidMinProcessesPerClass 0
            FcgidMaxProcessesPerClass 100
            FcgidConnectTimeout 30
            FcgidIOTimeout 360
            FcgidBusyTimeout 300
            FcgidMaxRequestLen 1073741824
            IdleTimeout 300
            ProcessLifeTime 3600
            # MaxProcessCount 1000
            DefaultMinClassProcessCount 0
            DefaultMaxClassProcessCount 100
            IPCConnectTimeout 30
            IPCCommTimeout 360
            BusyTimeout 300

    this is the template my control panel uses for new vhosts.
    any other ideas what logs to check or how to get more info?

Viewing 2 replies - 1 through 2 (of 2 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    thanks esmi, but I am pretty sure its a server related problem since I didn’t upgrade any wordpress installs recently and it happens on all (about 5 wordpress installs I host on this server) and all were fine until about a day ago…

    Just wanted to bring it up here, since googling doesn’t really bring up anything useful.
    some other oak had a similar problem with drupal 🙁

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘wordpress and some fastcgi problems’ is closed to new replies.