Support » Installing WordPress » WordPress and PHP 7.1

  • Resolved atom8bit

    (@atom8bit)


    Is WordPress compatible with PHP 7.1 yet? I can only find information on PHP 7.0, so I’m assuming not, but if anyone has additional insight, please let me know.

Viewing 3 replies - 16 through 18 (of 18 total)
  • I have connected on a hosting of PHP 7.1 (several websites including on WordPress there). After that on the website itrezultat.ru mistakes have appeared
    Warning: Parameter 1 to wp_default_scripts() expected to be a reference, value given in /var/www/ph343486/data/www/itresultat.ru/wp-includes/plugin.php on line 600<
    where it is necessary to correct?

    I’m having a problem with PHP 7.1.11 and WordPress 4.8.3 using nginx on a windows machine, everytime I get the error below:

    2017/11/03 20:22:24 [error] 6016#6060: *3 FastCGI sent in stderr: “PHP Fatal error: Uncaught Error: Call to undefined function mysql_connect() in C:\Sites\meustostoes\wp-includes\wp-db.php:1635
    Stack trace:
    #0 C:\Sites\meustostoes\wp-includes\wp-db.php(658): wpdb->db_connect()
    #1 C:\Sites\meustostoes\wp-includes\load.php(404): wpdb->__construct(‘root’, ‘mysql’, ‘meustostoes’, ‘localhost’)
    #2 C:\Sites\meustostoes\wp-settings.php(106): require_wp_db()
    #3 C:\Sites\meustostoes\wp-config.php(91): require_once(‘C:\\Sites\\meusto…’)
    #4 C:\Sites\meustostoes\wp-load.php(37): require_once(‘C:\\Sites\\meusto…’)
    #5 C:\Sites\meustostoes\wp-blog-header.php(13): require_once(‘C:\\Sites\\meusto…’)
    #6 C:\Sites\meustostoes\index.php(17): require(‘C:\\Sites\\meusto…’)
    #7 C:\Users\joel_\AppData\Roaming\Composer\vendor\cretueusebiu\valet-windows\server.php(132): require(‘C:\\Sites\\meusto…’)
    #8 {main}
    thrown in C:\Sites\meustostoes\wp-includes\wp-db.php on line 1635” while reading response header from upstream, client: 127.0.0.1, server: , request: “GET / HTTP/1.1”, upstream: “fastcgi://127.0.0.1:9000”, host: “meustostoes.app”

    mysqli is enabled on my php installation and everything seems to be all right, what can I do to solve this!? o.O

    WordPress 4.8 / Php 7.1.10 Plugins/Themes Fail to update. All get the same error message:

    [php7:warn] [pid 14155830] [client 9.X.X.X:57648] PHP Warning: Invalid argument supplied for foreach() in /e/x/X/snapblog/wp-admin/includes/class-wp-upgrader.php on line 369, referer: https://syssnap.xx.xx.net/snapblog/wp-admin/themes.php
    -or-
    [php7:warn] [pid 13959386] [client 9.X.X.X:58208] PHP Warning: Invalid argument supplied for foreach() in /e/x/X/snapblog/wp-admin/includes/class-wp-upgrader.php on line 369, referer: https://syssnap.xx.xx.net/snapblog/wp-admin/plugins.php?plugin_status=all&paged=1&s

Viewing 3 replies - 16 through 18 (of 18 total)
  • The topic ‘WordPress and PHP 7.1’ is closed to new replies.