Support » Everything else WordPress » WordPress and adsense

  • Resolved Broomy

    (@broomy)


    I’m having a problem with wordpress and adsense in that I can’t seem to get relevant ads on my homepages, but can on the post pages themselves. The ads pick up blogging ads rather than my topic (eg eyesurgerylasik.net) but then show relevant ads for the same article on the posted page.

    Any suggestions why this might be happening are greatly appreciated.

Viewing 15 replies - 1 through 15 (of 20 total)
  • How old is your site? If fairly new, that’s normal. It takes a while to get relevant ads on the home page. It will start happening – unless your homepage is more about blogs than eye surgery. :>)

    I have one site that’s 2 months old already and still pulls in “How to blog” type links… not as often as it did at first of course, but samboll’s right – it will take a little while.

    I have the same issue as well. The ads on the main blog page are always the same irrespective of what content is on it. But on the individual post pages themselves, they become contextual. My blog is about 2 weeks old. I understand this is to be taken w/ Adsense but am not complaining here, just sharing my probs 🙂

    srikat – don’t take it to adsense either… it’s because your site is only 2 weeks old.

    Thanks for the replies. The site is fairly new (2 weeks), but I just couldn’t understand why the same article from the homepage does have relevant ads on its archived page. I would have thought that the same ads would show on the homepage as it has the same content.

    I’ll see what happens over the next couple of weeks, but adsense must be picking up a blogging theme from somewhere, even though the only mention is the “powered by wordpress” footer link. This particular site has picked up a few relevant ads, however another site (conference-callservices.net) shows poor relevancy on the homepage. It’s annoying that some blogs that I put up show relevant ads straight away. This site’s also new so i’ll wait to see what happens.

    again – it’s not that they’re picking up a theme from somewhere… adsense can tell it’s a blog. adsense scans for MULTIPLE INSTANCES of a word or phrase in order to deliver relevant ads. if they don’t see any repetition (or if it doesn’t match their idea of sufficient repetition) they’re going to default to the blog ads stuff.

    it’s your content, and nothing more, that’s lacking here. the more keyword dense content you put up for your site’s topic, the sooner the ads will pick up on it. just don’t go spamming it all over the place.

    don’t get frustrated – it’s not like you’ve been singled out here, this is the way it works for bazillions of sites.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    You can reduce this amount somewhat by giving adsense clues as to where the important content on the page is.

    Edit your template. Around your post loops, add these bits of code:
    <!-- google_ad_section_start -->
    <!-- google_ad_section_end -->

    Around everything else (sidebars, footers, etc), add these bits of code:
    <!-- google_ad_section_start(weight=ignore) -->
    <!-- google_ad_section_end -->

    The idea is that Google is only going to look at what’s not “ignored” when figuring out what to use for adsense keywords. This will not totally eliminate the issue, but it will make the ads on the home page more relevant. However, it will take several days or even longer for any change to actually be noticed by Google’s crawlers. So give it a couple weeks at least.

    Template authors: It would be nice if this sort of thing was pre-implemented in templates already. Doesn’t hurt anything, since it’s just html comments.

    Ok, after getting frustrated with the same irrelevant ads coming up on the homepage I noticed that if I added index.php to the url, the ads are much more targeted. For example http://www.vehicleinsurance.info does not show the ads I would like but http://www.vehicleinsurance.info/index.php does.

    My question is, how can I make the site direct straight to the index.php file instead so that the ads that appear when someone finds my site are relevant?

    Any help is appreciated.

    Forcing my site to ..index.php causes public service ads to display (yikes!).

    Are you sure your sitemap
    http://www.google.com/webmasters/sitemaps/login
    is current and correct?

    Hey,all of you are way ahead of me.I just want to know how to put adsense on my blog.After its up and running then I will use the awsome tactics you are talking about here.

    ps.does anyone know how to add a signiture to the blog footer which includeds links to your website?

    GadeTerbob – If it’s the site sig under your username then I had no problems seeing ads, try again and see if you get any ads that you think are more relevant. Not sure if you’re happy with the ads on your homepage or not, but i’d be interested to hear if anyone else gets more targeted ads if they direct to index.php, and also if anyone has a suggestion for directing to the file when a visitor reaches my site.

    elcamino – For adsense anywhere in the actual text of a post I use http://www.acmetech.com/blog/adsense-deluxe/ but if you want to add adsense to anywhere else you can simply paste your adsense code to the sidebar or any other file.

    Open your footer file and add whatever links you would like in there if you want your links appearing at the bottom of the page.

    Elcamino, there are several plugins available, I use:
    http://www.acmetech.com/blog/2005/07/26/adsense-deluxe-wordpress-plugin/

    As for your ps, just edit the footer.php file located in
    ../wp-content/themes/WhatEverThemeYouUse

    Enjoy!!

    Sorry ’bout that, Broomy. I spent too long on this post reply page.

    Hitting Control Refresh with ..index.php caused the targeted ads to show again.

    I’ve no clue…. You could even call me “Clueless in the country.”

    Try changing wp admin –>>Options –>>General
    and put the index.php in the “WordPress address (URI):” field.

    Umm, that’s strange, i don’t seem to have any problems viewing ads with your site.

    Ahhhhhh, tried changing the address field and it seems to have messed up the layout. Can’t seem to change it back for some reason! Time to start pulling my hair out.

    Before you pull out any hair, I’ve had *lots* of heartache with browser and server caches when messing with this. Be sure you dump the browser cache and restart it. Some changes I’ve made just never show up. Point in case:
    When I first tried ..index.php the page only showed public service ads. After dumping the cache and using Control Refresh, relevant ads showed and they continued to show with both / and ../index.php and yes, I’m fairly happy with the relevancy *most* days. They even change with the page or article being viewed.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘WordPress and adsense’ is closed to new replies.