[resolved] WordPress Admin Suddenly Impossibly Slow (21 posts)

  1. emilycapito
    Posted 1 year ago #

    My site is blog.emilycapito.com

    I am so sick about this situation - any help would be very much appreciated and please keep it in layman's terms - I need step by step.

    I have been running my blog on wordpress with hosting through godaddy for over a year. I have never had this issue. A few weeks ago I switched themes to the Genesis Framework and website developer did the work to set up my site. It's worked beautifully until yesterday. Nothing changed between the transition to Genesis and now and it's been at least two weeks. I am on every other day, at least.

    When I login to the admin it takes forever and often throws a 500 server error. In navigating through any part of the admin panel - same thing. It takes 1-3 minutes to move from page to page and at least a third of the time, the whole thing times out and throws the server error.

    I started by calling GoDaddy yesterday and they reported that everything was fine on their end. They can pull up the site on both their in network and out of network computers, so sent me to look for a bad plugin.

    The problem became exponentially worse today when I actually spent a good deal of time creating a blog post this afternoon and so I called them up again. Got a good rep this time who really looked at everything and couldn't find any reason on their end that the issue is occurring. They indicated that the server error is a continuous connection error (?) indicating that numerous connections were trying to be made simultaneously and that a plugin must be looping or something.

    They advised to deactivate plugins one by one. I have 27 plugins (most are very simple - one for the favicon, one for the contact form, etc). I deleted all the inactive plugins and deactivated about 10 others before reading a post that suggested renaming the plugins folder via FTP so that you can test whether it is even a plugin issue.

    I was very hopeful that things would return to normal speed once I did this, but alas, no. In fact, I didn't even get to test anything before I got the following errors:

    W3 Total Cache Error: some files appear to be missing or out of place. Please re-install plugin or remove /home/content/29/10122729/html/blog/wp-content/advanced-cache.php.
    Warning: Cannot modify header information - headers already sent by (output started at /home/content/29/10122729/html/blog/wp-content/advanced-cache.php:23) in /home/content/29/10122729/html/blog/wp-includes/pluggable.php on line 876

    I assume these errors have resulted from the renaming of the plugins folder, so I am back to square one and renamed the file back to the correct name.

    I have already entered increased memory (128MB) into the wp-config.php file as was a solution to another user's similar issue to no effect.

    Another user mentioned port 80 being blocked by a firewall by the host (http://wordpress.org/support/topic/wp-admin-even-33-incredibly-slow/page/2). This seemed to click since the server error reads: "Internal Server Error...Apache Server at blog.emilycapito.com Port 80". I have called GoDaddy again specifically to demand they look for anything blocking or delaying php requests through port 80 - nothing.

    I did run it through gtmetrix as recommended:
    Page Speed Grade: C 79%
    YSlow Grade: A 90%

    Top Issues:
    Combine images using CSS sprites (lists my 6 social media icons) - F
    Inline small Javascript (lists one long link to inline) - E
    Serve scaled images (2 images are being resized by CSS) - D
    Inline small CSS - D
    Optimize Images - C

    Everything else is an A or a B.

    Pingdom's load time test - I get a wide range from 2.2 seconds to over 60 seconds - depending on whether the admin pages are trying to do something. There are 30 requests to load the home page. Domain size 377kb, nearly all images.

    I have deactivated all plugins at this point.

    I deleted all unnecessary images in case its a memory problem.

    I have tried to review the "logs" - the Apache Logs contain lines and lines and lines of indiscernible information. I don't see anything specific to errors and I honestly have no idea what I am looking at. The "Error Logs" folder has nothing in it.

    Will the change in speed be instantaneous once I find/disable the source or do I have to clear my cache with every single change and/or open a new browser to test whether it had an impact? (please god no)

    The website developer I used to build the site is going through some kind of medical treatment and while I have an email out to her, she is pretty inaccessible. I can't wait until she comes back online to get my admin panel working again!

    Read that some ISPs can "filter" port 80, so going to attempt to find someone with a brain at Centurylink tomorrow morning to see if they changed anything over there. Seems like a long shot.

    What should I try next?

  2. emilycapito
    Posted 1 year ago #

    Update: I read here (user "Premium23") of bumping the aforementioned memory line in the wp-config.php file to 1024 MB. Did so and OMG - lightning fast admin panel.

    Loaded the site in Incognito window - lightning fast.

    HOW WAS THIS THE ISSUE? Did I suddenly reach critical mass with that last image uploaded for my blog post today or would it be that something was changed by my host that caused the memory to become an issue out of nowhere? I had no discernible slowness until yesterday...then it was immediately sludge.

    Well...after about 12 hours of migraine-level stress, a silly little tweak is what fixes it. And it's only 11 PM here. Happy days.

    Hopefully my dialogue around the issue might help someone else find the strange solution sooner. I would certainly appreciate any insight into WHY this was the solution, but will settle for it working and insanity prevailing.


  3. emilycapito
    Posted 1 year ago #

    Update: Apparently this was only a temporary solution or the deactivation of all my plugins suddenly caught up at the exact same moment that I made the above change.

    Reactivated all plugins. Updated several that had updates waiting - everything was incredibly fast.

    15 minutes later we are back to 1-3 minute admin panel load times to do anything and back to 8-15 second load times for any live blog page.

    What should I do next? Very worried this is going to get worse again.

  4. jnhghy
    Posted 1 year ago #

    First of all make sure you are up to date with all your plugins and with wp.
    Then if things are still slow it usually means a plugin is not working as it should, you have to detect which one is it... to do that, disable all the plugins then reactivate them one by one and test the backend speed after each activation to see exactly which one is causing this... if you find the one which is slowing down you backend then you'll have the option to replace it or to contact it's developer and let him/her know about your issue...

  5. emilycapito
    Posted 1 year ago #

    Thanks, jnhghy.

    I have deactivated all of my plugins at once with no change and have now gone through and deactivated each of them one by one with no change.

    Additional information: On my hosting plan I have several websites, two are built on wordpress. Both wordpress sites are experiencing the same issue.

    The blog mentioned here is HUGE, had 27 plugins (now down to 16 in case it helps), and is constantly being updated with new content.

    The other wordpress site is static, small, has 6 plugins, and is updated once a month at most.

    They share the following plugins:
    - Captain Favicon
    - WordPress SEO

    I have run the P3 plugin profiler on the blog and the WordPress SEO is taking up the highest percentage, but my speed in the admin panel and the 500 server errors still exist when it is deactivated.

  6. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Deactivate all plugins, revert to Twenty Thirteen theme and see if it makes any difference to speed.

  7. emilycapito
    Posted 1 year ago #

    Thanks for the suggestion, Krishna.

    No, no change :(

  8. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Check if this optimization guide is of any help to you.

    Also check your page speed at gtmetrix.

  9. emilycapito
    Posted 1 year ago #

    Thanks Krishna, my gtmetrix results are in my original post and I have attempted to complete most available optimization steps; however, my site is not super large and my results are terrible on gtmetrix, so I think the server errors and slowness problem has another source.

    Can anyone else advice on steps to take at this point?

  10. emilycapito
    Posted 1 year ago #

    @WPyogi - I do not believe the the below request is a duplicate topic, and I find it EXTREMELY rude that you would close the separate topic without allowing some response as to why this NOT a duplicate topic first. I have no way of responding to you there now, which will only serve to clutter this topic.

    Why these are separate in my mind (and if they aren't in your holy opinion, please provide direction on WHY and be helpful instead of the forum police):

    - THE TOPIC ABOVE is specifically my admin panel throwing 500 errors and dragging on every admin page. It is still unresolved and at this point I working with GoDaddy to try to find a solution. It began out of nowhere two days ago.

    - THE ONE BELOW THAT YOU CLOSED WHILE STILL UNRESOLVED is specific to my live site going after a bit of code somewhere. The delay for this bit of code is minor in comparison to the delay coming from the initial request to fetch the site, which is 40-60 seconds now. I highly doubt they are related to one another as the code calling this PNG has obviously been there for awhile causing no real issues in the back-end. There were absolutely no changes to any stylesheets, plugins, or the like before the ABOVE ISSUE started occurring two days ago.

    If someone else can take a shot at helping me look in different locations for the bit of code or url that is looking for an image, that would be helpful.

    "So I am troubleshooting some issues and have discovered through the pingdom speed test an issue that is causing a slower than good load time. There is a request for an image file (header.png) that does not exist, result in a long wait (10-22 seconds) and then the 403 error.

    I am not an expert on wordpress; however, I would imagine that the code trying to call this image would be found in the CSS stylesheet for my theme. I am using the Genesis framework with a custom child theme. The Genesis theme is brand new and was never tampered with - just a fresh install to support the child theme.

    I have searched through the child theme's stylesheet and every other php file associated with it (there are only four) and there is not a single instance of header.png.

    I have reviewed my plugins one by one and none of them would ever call an image - they are all functional plugins, for SEO and such, although I have not gone through each of their CSS sheets. That being said, I disabled all of them and the error during the speed test was still present.

    The only place I did find a reference to header.png was in my old theme's stylesheet, which was deactivated weeks ago when I replaced it with Genesis. I went ahead and deleted the whole theme in entirety in case it was somehow causing the request.

    I have also cleared my cache.

    I am using W3 Total Cache, but I have cleared it multiple times and the request is still made when I have it deactivated.

    Where else should I look for the source of this dang request? Is it possible that my wordpress install is just f-ed up and needs a fresh install?

    Thanks in advance for your direction!"

  11. WPyogi
    Forum Moderator
    Posted 1 year ago #

    For help deactivating W3TC properly, see their forum:


    The standard test is to try a default theme with ALL plugins deactivated.

  12. WPyogi
    Forum Moderator
    Posted 1 year ago #

    And BTW, this IS the same issue.

  13. WPyogi
    Forum Moderator
    Posted 1 year ago #

    There were absolutely no changes to any stylesheets, plugins, or the like before the ABOVE ISSUE started occurring two days ago.

    And that suggests a server/hosting issue.

  14. Dave Naylor
    Posted 1 year ago #

    For the header.png request, look in your theme's functions.php file. The file is being called by jQuery and there may be a relevant line or two of code in there.

  15. emilycapito
    Posted 1 year ago #

    If you read above, I have tried deactivating all plugins - they are all deactivated now. I have tried the default theme as well multiple times. Both of the above issues remain regardless.

    Both issues were also present before I ever installed W3 Total Cache as I added the plugin after they began.

    Also, the link to "deactivate W3TC" properly was fairly unhelpful, although I will got through the steps I found to remove it entirely since other folks do have issues with it.

    Here is better link for future reference so that folks don't pull their hair out looking for help in the 160 pages of unresponded support tickets: http://redstarwebdevelopment.com/2013/05/03/how-to-remove-w3-total-cache/

    That being said - the issues above were present before, during, and after W3TC. Help?

  16. emilycapito
    Posted 1 year ago #

    @wpyogi - I will get on the phone with GoDaddy again now and see if I can find intelligence.

    WPRanger - thanks for the tip. Would you expect to find the actual reference to header.png in the function file? If so, it is not there. Would I look for some other type of code instead? Sorry I am not the best at this, but figured that image has to be referenced somewhere. Happy to paste my functions.php info if helpful, it's pretty minimal.

  17. pchere
    Posted 1 year ago #

    Contact your hosting and they will see it is a database issue. Once when we had very slow WordPress, hosting guys informed that some database tables had crashed, they repaired the database and all was well.

  18. Dave Naylor
    Posted 1 year ago #


    Just do a search on the file. If it were me I'd ssh to the server and just grep the lot :)

    grep -R header.png *


  19. emilycapito
    Posted 1 year ago #

    Thanks, P.Chandra - I am on hold with them now - finger crossed!

    WPRanger - That sounds like a nifty as heck trick! Do you know of a dummy tut (only finding pretty adv stuff) - here's where I'm at:
    - Not sure what SSH is, but it looks like I would need to download Putty to use SSH to connect to my server (I'm on Windows 7)
    - Went to the download site and it indicates I need my SSH credentials for the thing to work - would my host supply these?


  20. emilycapito
    Posted 1 year ago #

    GoDaddy was of little help - they did FINALLY confirm that the live site load time issues were due to "latency on specific nodes on the grid that they are working to smooth out" but blame the 500 server errors on WordPress.

    This doesn't make sense since the server errors appear at the same time that the load times jump and only when I am performing some action on the admin side (deactivating a plugin, activating a theme, etc). Denied any issues (filtering, firewall, etc) that could impact PHP activity through port 80. Denied any database issues.

    I do think I found the SSH info while exploring in my hosting panel, so going to attempt to fix the other issue of the mystery PNG file now while I wait to see if I get another server error, having reactivated a group of plugins.

    I really appreciate everyone's input and suggestions thus far. My hope is that this is a GoDaddy issue that they refuse to acknowledge and that the grid "latency" issues were and are the source of the server errors when I was trying to work in the backend.

  21. emilycapito
    Posted 1 year ago #

    No problems for the last couple of hours, so marking as resolved. Will reopen if the mystery server errors reappear in the next little bit. Never found the offended image code - SHS was just over my head, so sent a request off to my website programmer to look into when she can.

    Thanks all.

Topic Closed

This topic has been closed to new replies.

About this Topic