WordPress.org

Support

Support » Miscellaneous » WordPress adding extra apostrophes on post update

WordPress adding extra apostrophes on post update

  • chrisbrunt1234

    @chrisbrunt1234

    Hi,

    I’m having trouble with WordPress adding extra apostrophes every time I update a post. A post will publish fine the first time but with each update post after a extra apostrophes is added.

    For example

    Chris’s will become Chris”s then Chris”’s

    This happens on a few different Macs all running Leopard and using WordPress 2.8.5.

    Anyone have any ideas as to whats causing it? Have I set something up wrong somewhere?

    Cheers

    Chris

Viewing 1 replies (of 1 total)
  • chrisbrunt1234

    @chrisbrunt1234

    Ok so I have managed to fix this myself….

    Basically its something called magic qutoes that need to be turned off in you hosts php settings. I couldnt get them turned off by my hosting company as I have a shared hosting package.

    I tried editing my .htaccess file but that just resulted in server errors.

    The solution is to create your own “php.ini” file. I just used a text editor to create a file called “php.ini”. The file needs to contain the lines:

    ; magic quotes should not be used
    magic_qutoes_gpc = Off

    then the file needs to be uploaded into your wordpress directory inside wp-admin.

    wordpress/wp-admin

    Thats it, worked for me anyway! No more ””””””

    Chris

Viewing 1 replies (of 1 total)
  • The topic ‘WordPress adding extra apostrophes on post update’ is closed to new replies.
Skip to toolbar