Support » Fixing WordPress » WordPress adding an excessive meta description

  • Resolved moafi

    (@moafi)


    I have a WordPress running with Woocommerce and a commercial theme. My problem is that something is adding an extra meta tag(og:description) and it is getting on my nerve since it’s content which is completely irrelevant displays on social media while sharing our links. Here’s the web address: [ redundant link removed ] and here’s the code :

    
    meta property="og:description" content="[rev_slider alias="index"] جدیدترین محصولات تومان۵۷۶,۰۰۰ STAR WARS JEDI FALLEN ORDER نمره ۴٫۰۰ از ۵ افزودن به علاقه مندی ها مقایسه افزودن به سبد تماس بگیرید Watch Dogs Legion افزودن به"
    

    If you view source the home page, you can find this string. I tried disabling all the plugins one by one and It got disappeared when I disabled the woocommerce! I tried using the String Locator plugin and I looked up “og:desc” and it gave me two strings from Yoast SEO but when I disable Yoast SEO, the main meta description tag disappears and the excessive one remains!!! I contacted the theme author and they came up with no resolution. I would be grateful if someone could help me finding this string’s source. Best,

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    WordPress itself does not add a meta-description. That’s plugin and/or theme territory.

    So, let’s do the troubleshooting dance…. 🙁

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you can install plugins, install “Health Check”: https://wordpress.org/plugins/health-check/ On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site. You can then use its admin bar menu to turn on/off plugins and themes one at a time.

    moafi

    (@moafi)

    Hi!
    Thank you Steve!
    Resolved!
    Had to disable the Open Graph option on the Theme control panel!

    • This reply was modified 1 month ago by moafi.
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.