Support » Plugin: WordPress Access Control » WordPress Access Control plugin not working with new WP version

Viewing 5 replies - 1 through 5 (of 5 total)
  • Same Problem here. Need help. Need this plugin.

    PHP Warning: get_class() expects parameter 1 to be object, string given in /.../wordpress-access-control/wordpress-access-control.php on line 614

    It’s broken with WP 4.4.1 too. Somebody can help?

    celsocos

    (@celsocos)

    I also have issues with WP, now 4.4.2 and PHP warnings too.

    Have to remove it, hope this plugin get some mantenance because it is a good one (until now…)

    In file wordpress-access-control.php in line 614 I changed

    if (isset($args[‘walker’]) && get_class($args[‘walker’]) == ‘WpacSecureWalker’) {

    to

    if (isset($args[‘walker’]) ) {

    I know this could break your site if you have a configured menu, but my site does not have a configured menu. This made my menu work and got rid of the error:

    Warning: get_class() expects parameter 1 to be object, string given

    Thx brendon.raw
    This was helpful for me and my sites are running without error.
    I don’t have a configured menu.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WordPress Access Control plugin not working with new WP version’ is closed to new replies.