Support » Theme: Twenty Nineteen » WordPress 5.X doesn’t show “post to page” option on reading settings

  • Hello,

    I wanted to create a separate blog page and publish posts to that page, keeping the homepage as the business page. But no option is displayed as “Post Page”, only “Homepage”. How can I set up Post page?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Go to Dashboard->Appearance->Customise->HomePage Settings.
    On that panel you can see that the Homepage can be either your latest posts or a static page. If you have chosen static page, there will be a dropdown of your current pages. Choose your business page there. Below that, there is another choice “Posts page” — there you can choose “Blog”.

    I believe this will sort it out for you.

    Thread Starter jcalvarezvg

    (@jcalvarezvg)

    Stilman Davis:

    Not sure if you read my question.

    “Posts Page” option doesn’t appears, so I cannot select anything in there.

    Thread Starter jcalvarezvg

    (@jcalvarezvg)

    OK, I saw the option within my theme customize options (udesign)
    However, when I change Post Page to my Blog page it doesn’t save the setting.

    You need to save(publish) when you have made your changes. Did you do that?

    It also sounds as if you are using a theme other than Twenty Nineteen and a plugin for your customisation.

    I was looking at the core theme without any plugins.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.