Support » Fixing WordPress » WordPress 5.5 Fix – Downgrade it to 5.4.2 !

  • The best Solution is to downgrade to 5.4.2 Using the WP Downgrade Plugin by Version 1.2.1 | By Reisetiger. It resolves my issue with the WordPress 5.5.

    I had issues with the Visual Composer was broken and the theme options on my pages were not displaying well. Now with the downgrade to 5.4.2 is working fine.

    Cheers

    • This topic was modified 2 months, 2 weeks ago by veerajramdhun.
Viewing 15 replies - 1 through 15 (of 27 total)
  • Hi 👋🏼

    Although rolling back is one solution, it doesn’t help to resolve the problem. Indeed, depending on your site, you may find some content lose as a result of reversing the installation.

    Fixing-forward is, imo, the better solution, if you can do this.

    It resolves my issues with the WordPress 5.5

    What issues were you having with the update? What are you going to do now to make sure you site works with the next WordPress release?

    Thanks

    A lot of problems with 5.5, java slider and adwords sidebar don’t show.

    Downgrade is a fast solution.

    @dartiss

    People can’t be a beta tester with their sites in production.

    @jprida yes Downgrade is the best solution for a quick fix.

    Downgrade is a fast solution.

    It is. But won’t get to the bottom of your issue.

    People can’t be a beta tester with their sites in production.

    Absolutely true. But you’re assuming this is due to a bug and not because of planned behaviour in the release – you may not find any future release of WordPress will resolve the problems you’re seeing.

    Did you not experience the problems when you tested the Beta or R1 before yesterday?

    A lot of problems with 5.5, java slider and adwords sidebar don’t show.

    I’ve had a quick look and can’t find “java slider” or “adwords sidebar” in the plugins directory – otherwise I would have taken a look at these. Both sound as if they may be reliant on JQuery – a change was made to this in 5.5, which may cause some older plugins to break. If you’ve not done so already, check the plugins’ forum to see what other people are saying it. Also see if the developer has released a new version that may resolve it.

    @dartiss yes I had an urgent update to do on the website – Visual Composer was broken. that’s why I have used the downgrade as a quick solution for me. It worked for me and let’s hope for a new WordPress release or the website theme updates with the fix.

    yes I had an urgent update to do on the website – Visual Composer was broken. that’s why I have used the downgrade as a quick solution for me.

    Understood. The downgrade is a quick solution.

    let’s hope for a new WordPress release or the website theme updates with the fix.

    You are making an assumption and it may be an old plugin causing it – so future WordPress updates may not resolve this. It may be better, when you have time, pushing the upgrade through again and trying to get to the bottom of the problem. If you do, please come to the forum and let us know what’s happening and we can help you resolve it.

    I also have problems and are waiting for the hosting company to reinstall to yesterdays version. Maybe deactivation all the Plugins before upgrading might help?

    Regards

    Thanks so much – worked for me!

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    See if this is jQuery related… https://wptavern.com/major-jquery-changes-on-the-way-for-wordpress-5-5-and-beyond

    See if installing https://wordpress.org/plugins/enable-jquery-migrate-helper/ helps. If so, please let us know and the plugin developers!

    See if installing https://wordpress.org/plugins/enable-jquery-migrate-helper/ helps. If so, please let us know and the plugin developers!

    Thanks, i was ready to downgrade also but the issue is with jquery as you stated. it affects wpbakery and i guess visual composer also, although the two are often conflated despite being different now.

    Thanks again

    @sterndata After updating to WordPress 5.5 my theme stopped working properly as well. I am using the OnePress theme (https://www.famethemes.com/themes/onepress/).

    I installed Enable jQuery Migrate Helper and it fixed the issue.

    Does the maintainer of the theme need to make code changes to fix this properly?

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    >> Does the maintainer of the theme need to make code changes to fix this properly? <<

    Yes. Please let them know.

    @cbfs Thank you so much for the tip. Enable jQuery Migrate Helper fixed the issue while waiting for some plugins to release jQuery updates/fixes for WordPress 5.5 compatiblity.

    This is more of an annoyance than a real issue, but it has nothing to do with a theme or plugin: Select All plugins or themes doesn’t work on the multisite WordPress Updates page unless you enable jQuery Migrate.

    • This reply was modified 2 months, 1 week ago by swampgeek.

    Hi,

    I added the Migrate Helper Plugin, then upgraded to 5.5 Had 2 types of error messages.

    1 refers to the Theme, which I have reported to the supplier.

    2 Migrator shows this message. “jQuery is not compatible with Quirks Mode”

    Help appreciated.

    Regards
    Drachsi

Viewing 15 replies - 1 through 15 (of 27 total)
  • You must be logged in to reply to this topic.