Support » Plugin: Import any XML or CSV File to WordPress » WordPress 5.5. compatibility

  • Resolved Andrea Fercia

    (@afercia)


    Hello. It is important to note that WordPress 5.5, which will be released on August 11, will remove the “jquery-migrate” script.

    As a consequence, any code that still uses jQuery live() and possibly other old code will likely break. Most notably, WP All Import uses live() and that will now trigger an Uncaught TypeError “.live is not a function” that will break most of the JavaScript in all the WordPress admin pages.

    See related WordPress Trac tickets:
    https://core.trac.wordpress.org/ticket/50820
    https://core.trac.wordpress.org/ticket/37110

    This means all users that upgrade to WordPress 5.5 and have WP All Import activated (and likely other plugins from your team) will face major breakages in the WordPress admin. It is recommended to update old jQuery code as soon as possible.

    Related dev note on the WordPress Make blog:
    Updating jQuery version shipped with WordPress

    Updating jQuery version shipped with WordPress

Viewing 6 replies - 1 through 6 (of 6 total)
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘WordPress 5.5. compatibility’ is closed to new replies.