Support » Plugin: Sticky Side Buttons » wordpress 5.5 ?

  • Resolved Gérald Mardirossian

    (@gerald-mardirossian)


    Hello,

    the plugin was working fine until I updated this morning to wordpress 5.5
    Maybe update is on his way ?

    you can check on my site that it is not working well anymore > virtueltime

    thanks for any news

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Maeve Lander

    (@enigmaweb)

    Hi @gerald-mardirossian. The Sticky Side Button plugin has been tested with 5.5 and is compatible. I’ve updated my demo site to 5.5 so you can see it running perfectly there: http://demo.enigmaweb.com.au/.


    With the update to WordPress 5.5, a migration tool known as jquery-migrate was removed from core. This can lead to unexpected behaviours in some themes or plugins which run older or custom code.

    Looking at your site using my browser error console I do see some JS related errors.

    Uncaught TypeError: $ is not a function
        at autoptimize_single_cddca1ff9c0d0eb77801ec2bf8eb942c.js:1
        at dispatch (jquery.js:3)
        at r.handle (jquery.js:3)
        at c (rocket-loader.min.js:1)

    If these started happening directly following the 5.5 update then it would be worth verifying if the absence of jquery-migrate is the cause.

    I’d recommend you start by installing the Enable jQuery Migrate Helper plugin

    If things work again once this is activated, then it confirms the issue relates to removal of jquery migrate. You’d then need to work out which plugin or bit of theme code is using the deprecated code and get that fixed up.

    Hope that helps point you in the right direction 🙂

    • This reply was modified 1 year, 3 months ago by Maeve Lander.
    Thread Starter Gérald Mardirossian

    (@gerald-mardirossian)

    Yes, thanks. Looks like it is working fine now 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘wordpress 5.5 ?’ is closed to new replies.