Support » Plugin: Featured Video Plus » WordPress 5.3 Error Notice: class-oembed.php is deprecated since version 5.3.0!

  • typon

    (@typon)


    Since updating to wordpress 5.3 I am seeing this error.
    I’ve narrowed it down to Featured Video Plus as the error message disappears if I disable this plugin.
    The full error message is:
    Deprecated: class-oembed.php is deprecated since version 5.3.0! Use wp-includes/class-wp-oembed.php instead. in /var/www/vhosts/sk10398.srv10.schwarzkuenstler.info/httpdocs/wordpress/wp-includes/functions.php on line 4903

Viewing 6 replies - 1 through 6 (of 6 total)
  • mythicalbot

    (@mythicalbot)

    Hi, until the developer solves this, I found how to get rid of the problem, look into the featured-video-plus folder, under PHP, there is a file called class-oembed.php, open it in a text reader (I use notepad ++), simply replace every class-oembed you see in the file with class-wp-oembd that will solve it.

    devbikram

    (@devbikram)

    I am also facing same issue. After I upgrade my WordPress version.

    Deprecated: class-oembed.php is deprecated since version 5.3.0! Use wp-includes/class-wp-oembed.php instead. in /var/www/html/wp-includes/functions.php on line 4903

    Thread Starter typon

    (@typon)

    @mythicalbot

    hey thank you for you help.
    I looked it up, but sadly it was already changed.

    Thread Starter typon

    (@typon)

    @mythicalbot

    Hey i searched in the wrong folder 🙁

    Now i got it and perfect it works 🙂
    Thank you really much 🙂

    @mythicalbot thanks for taking time to post your effective work-around!

    @typon

    Which file did you edit (can you just publish the path alone)?

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.