Support » Plugin: Advanced Custom Fields » WordPress 5.3 date and time

  • After updated to WordPress 5.3, custom date/time fields are displayed incorrectly.
    Even on post editor pages, after we input a date/time field and save the post, the different date/time appears on the updated editor page.

    FYI, the issue occurs on the system with ACF Pro, WPML, and ACF Multilingual.

    • This topic was modified 2 years, 2 months ago by kaz-nishimura.
Viewing 5 replies - 1 through 5 (of 5 total)
  • The same issue having here with Pro, if I enter today in a date field and update the post, the date is saved as yesterday. And then update again, it becomes two days before today.
    Probably it was introduced after the 7.3 release.

    I am having the same issue.

    Here is a screen recording documenting the issue:

    Thread Starter kaz-nishimura

    (@kaz-nishimura)

    We rolled back to WordPress 5.2 but it seems the issue is due to the use of date_default_timezone_set() for our site.

    See discussions at Date/Time component improvements in WordPress 5.3

    I’ve solved the problem inserting an additional [space] before the “Y”

    -> echo date_i18n(‘l j F Y’)

    If it helps until the official fix.

    Ciao!

    PS: You can’t see in the above example because publishing strips it away, but there are two spaces between “F” and “Y”, on my site this works. Let me know if in yours too.

    • This reply was modified 2 years, 2 months ago by franciskje.

    This is the repy I received when I submitted a ticket on the ACF website. It worked for me.

    =======================
    Hi there!
    thank for reaching out to us.

    I believe the issue you are experiencing is due to a change in the date_i18n() function causing values to be modified via the timezone setting.

    This issue does not effect the value saved into the DB, but occurs when loading and “formatting” the value.
    We have a few similar bug reports at this time, and will investigate this shortly.

    For now, can you please try the following fix: Edit the file “includes/api/api-helpers.php” on line 4117 and change from:
    return date_i18n($format, $unixtimestamp);
    to:
    return wp_date($format, $unixtimestamp);

    I hope this helps.

    Thanks,
    James

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WordPress 5.3 date and time’ is closed to new replies.