Support » Plugin: dsIDXpress » WordPress 5.3 Compatibility?

  • linux4me2

    (@linux4me2)


    I’ve been using the dsIDXPress plugin on WordPress 5.2.4 and PHP 7.2 successfully for a while, but I’d like to upgrade to WordPress 5.3, and currently, the dsIDXPress plugin shows it’s only tested up to v. 5.1.3.

    I checked the code and found the following issues:

    
    FILE: ...c_html/wp-content/plugins/dsidxpress/widget-idx-quick-search.php
    ----------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ----------------------------------------------------------------------
     352 | WARNING | Function each() is deprecated since PHP 7.2; Use a
         |         | foreach loop instead
    ----------------------------------------------------------------------
    
    FILE: ..._html/wp-content/plugins/dsidxpress/widget-idx-guided-search.php
    ----------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ----------------------------------------------------------------------
     461 | WARNING | Function each() is deprecated since PHP 7.2; Use a
         |         | foreach loop instead
    ----------------------------------------------------------------------
    
    FILE: ...ectc/public_html/wp-content/plugins/dsidxpress/widget-search.php
    ----------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ----------------------------------------------------------------------
     3 | WARNING | Use of deprecated PHP4 style class constructor is not
       |         | supported since PHP 7.
    ----------------------------------------------------------------------
    

    Since those are just warnings for deprecated functions and not errors, none of them should prevent dsIDXPress from running with WordPress 5.3 and PHP 7.2, but I have no way of checking beyond that to see if any of the changes in WordPress 5.3 might break something other than going ahead with the upgrade. Before I upgrade a production site, can you tell me if it’s compatible with 5.3?

  • You must be logged in to reply to this topic.