Support » Fixing WordPress » WordPress 5.3 and Classic Editor – upload files via post not working

  • Hi, please can you help with a new problem? After upgrade to WordPress 5.3 and using Classic Editor from WP team it’s not working to upload files directly via post (there’s still a button to upload files, but not clickable, no response), it works only via Media library (in menu left side). I tried other plugins from category “Classic Editor” and no one is able to help this error with uploading files directly via post…

Viewing 15 replies - 1 through 15 (of 16 total)
  • Hi There!

    Are we talking about this button https://cloudup.com/cYDc7H2XMWZ ?

    It seems to work properly for me. Any details you can share about your installation, browser?

    Did you try disabling other plugins to see if there’s any conflict?

    thanks.

    After click on Add Media there is a button Upload Files, but not clickable – do nothing after click – https://imgur.com/a/CtW9Cni. When I click on Media Library, I see all already uploaded files.

    Now I see that the problem is occuring because of plugin Multiple Post Thumbnails – https://wordpress.org/support/plugin/multiple-post-thumbnails/, it seems that this plugin is not updating for last major WP releases. So I will just need an alternative plugin for adding second thumbnail for posts.

    Thank you!

    I have had this reported by a user of a site I manage as well. If you don’t click on “Upload Files” and instead just drag the file into the media library does this upload for you? When I tried that it worked for me.

    What I do note in the console logs when clicking on the “Upload Files” in the image popup I get

    Uncaught TypeError: Cannot convert undefined or null to object from the file load-scripts.php

    Uncaught TypeError: Cannot convert undefined or null to object
        at g.cleanup (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils,jquery-ui-widget,jquery-ui-position,jquery-ui-core,jquery-ui-mouse,jquery-ui-sortable,underscor&load[chunk_1]=e,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,jquery-ui-tooltip&ver=5.3:66)
        at g.off (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils,jquery-ui-widget,jquery-ui-position,jquery-ui-core,jquery-ui-mouse,jquery-ui-sortable,underscor&load[chunk_1]=e,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,jquery-ui-tooltip&ver=5.3:66)
        at r (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils,jquery-ui-widget,jquery-ui-position,jquery-ui-core,jquery-ui-mouse,jquery-ui-sortable,underscor&load[chunk_1]=e,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,jquery-ui-tooltip&ver=5.3:66)
        at l (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils,jquery-ui-widget,jquery-ui-position,jquery-ui-core,jquery-ui-mouse,jquery-ui-sortable,underscor&load[chunk_1]=e,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,jquery-ui-tooltip&ver=5.3:66)
        at h.Collection.n.off (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils,jquery-ui-widget,jquery-ui-position,jquery-ui-core,jquery-ui-mouse,jquery-ui-sortable,underscor&load[chunk_1]=e,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,jquery-ui-tooltip&ver=5.3:66)
        at i.c.<computed> [as off] (media-views.min.js:1)
        at i.dispose (media-views.min.js:1)
        at i.dispose (media-views.min.js:3)
        at i.remove (media-views.min.js:1)
        at load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils,jquery-ui-widget,jquery-ui-position,jquery-ui-core,jquery-ui-mouse,jquery-ui-sortable,underscor&load[chunk_1]=e,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,jquery-ui-tooltip&ver=5.3:65

    I am experiencing the exact same error as above. My site DOES have the classic editor installed as well. The problem isn’t actually occurring on the media upload page at all. I can upload a file by dragging it into the ‘Add New’ Interface just fine.

    On the page for any post type, if I hit the ‘Featured Image’ link, the ‘Uploads’ tab will not load. I can see that same javascript error as above in my console. It looks like its originating from backbone:

    Uncaught TypeError: Cannot convert undefined or null to object
    at g.cleanup (backbone.min.js?ver=1.4.0:1)
    at g.off (backbone.min.js?ver=1.4.0:1)
    at r (backbone.min.js?ver=1.4.0:1)
    at l (backbone.min.js?ver=1.4.0:1)
    at h.Collection.n.off (backbone.min.js?ver=1.4.0:1)
    at i.<computed> [as off] (media-views.min.js?ver=5.3:1)
    at i.dispose (media-views.min.js?ver=5.3:1)
    at i.dispose (media-views.min.js?ver=5.3:1)
    at i.remove (media-views.min.js?ver=5.3:1)
    at underscore.min.js?ver=1.8.3:1

    This happened when I updated to 5.3. It looks from the notes like Backbone was updated to 1.4.0 from 1.3.3. Could that be party of the problem here?

    • This reply was modified 3 weeks, 5 days ago by Jon Boss.

    @jonboss did you try disabling plugins to see if there’s a conflict?

    Just tried them one by one and found my issue! It’s a problem with this outdated plugin: https://wordpress.org/plugins/enhanced-media-library/ for me. I’ll add a post there, cheers.

    Hello @jonboss did you somehow solve your problem with Adding Media classic plugin?

    After updating wordpress to 5.3I was forced to use BLOCK edit but I want to get classic version. Is there any solution to fix it?

    Thanks for help.

    • This reply was modified 3 weeks, 4 days ago by blacknighter.

    @blacknighter you can install the classic editor plugin to rollback to the previous editor https://wordpress.org/plugins/classic-editor/

    @youknowriad I did it and problem still exists. I can’t normally add any media files 🙁 button Upload Files is not clickable – do nothing after click.

    • This reply was modified 3 weeks, 3 days ago by blacknighter.

    The media problem is unrelated to the block editor, I was just replying to how you can rollback to the classic editor.

    For the media issue, I suspect it’s a conflict with one of your existing plugins, try disabling them one by one.

    Hey, @blacknighter. Yeah I can confirm that I do also have the classic editor installed on the site that had this issue. The problem was indeed with a different plugin though. After disabled ‘Enhanced Media Library’, I now am on 5.3 with classic editor running and everything is OK.

    rglcote

    (@rglcote)

    @jonboss I had the same problem, with the same plugin! I deactivated it and everything works again. Thanks for the help 🙂

    @jonboss @rglcote Thank you! This definitely helped fast-track to me finding out this issue I was having was also being caused by Enhanced Media Library (happening for both the free version on WP.org and the paid Pro version.)

    I’ve created a support topic at https://wordpress.org/support/topic/potential-fix-wordpress-5-3-conflict-compatibility-error/ to help Enhanced Media Library avoid this issue for those that might still want to use it.

    I can confirm this is happening to me as well, WordPress 5.3, classic editor, and enhanced media library “stalls” on upload. Using the workaround of directly uploading from media library “add new” did the trick.

    hoko01

    (@hoko01)

    Dear all,

    after disabling https://wordpress.org/plugins/enhanced-media-library/ it works as usual.

    Thanks for the help!

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.