Support » Plugin: Advanced Editor Tools (previously TinyMCE Advanced) » WordPress 5.1 required?

  • Hi Andrew,

    I just updated to the latest version of this plugin from WordPress 4.9 backend and just then noticed that advertised required WP version is 5.1. Should I expect problems on 4.9 then now that I have the latest version?

    Btw. I thought that WordPress won’t offer plugin update if minimum WordPress version is not met?

    Also, you forgot to update Stable tag in readme.txt – it still says 5.0.1.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Btw. I thought that WordPress won’t offer plugin update if minimum WordPress version is not met?

    Ignore that – I just realized this is likely due to our custom setup in which version number in User-Agent header is stripped from external requests.

    Plugin Author Andrew Ozz

    (@azaozz)

    Ah, I see. Yes, WP should only offer plugin updates when the minimum version is met.

    Generally there shouldn’t be any problems, but the changes are untested. The required version is WP 5.1 because TinyMCE was updated in core. So the TinyMCE plugins that are in TinyMCE Advanced (TMA) match the TinyMCE version in core: 4.9.2. That was the only update so you can revert to TMA 5.0.1 on WP versions < 5.1 without loosing any functionality.

    Also, you forgot to update Stable tag in readme.txt – it still says 5.0.1.

    This is a plugin repo “technicality”. The plugin’s release is in a svn tag that is created prior to releasing. The Stable tag in the readme controls which svn tag will be packaged/zipped and offered for downloading but it is taken from svn trunk (i.e. the development version). Generally once created an svn tag shouldn’t be changed/updated, so the value for Stable tag ends up being one version behind in the readme in the downloaded zip, but is correct in svn trunk in the repo.

    I probably should start updating that in the svn tags, like https://plugins.svn.wordpress.org/tinymce-advanced/tags/5.1.0/ to match trunk https://plugins.svn.wordpress.org/tinymce-advanced/trunk/ to avoid any misunderstandings.

    • This reply was modified 1 year, 8 months ago by Andrew Ozz.
    • This reply was modified 1 year, 8 months ago by Andrew Ozz.

    Thanks for the feedback and clarification! I’ll downgrade to 5.0.1 then to be on the safe side 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘WordPress 5.1 required?’ is closed to new replies.