Support » Plugin: Amazon Link » WordPress 5.1

  • Resolved MildPeril

    (@mildperil)


    I just upgraded to WordPress 5.1 and the links don’t appear any more. Are there any plans to upgrade the plugin to work with 5.1?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author paulstuttard

    (@paulstuttard)

    Hi,

    I’m running the plugin on a WordPress 5.1 site with no issues. Although the plugin is not compatible with the Gutenburg editor, it should still display the links when the site is viewed.

    Amazon have severely reduced the rate at which the plugin can call the Amazon Web Service, it could be this is causing links to not appear? Enabling the plugins cache facility should help with this issue.

    Paul

    Thanks for the quick reply Paul. Caching is on, and the plugin is generating the HTML in the page, but it doesn’t contain any image links except for the 1×1 and a ‘no image available’ one which isn’t visible on the page. This applies to all the templates. I suspect I’ve done something stupid so I’ll look into it more.

    Just noticed I’m getting a 0 for FOUND, even though the ASIN is correct. Could this be caching or another problem conecting to Amazon?

    Plugin Author paulstuttard

    (@paulstuttard)

    If the plugin encounters any error trying to retrieve the product info, then it sets found to 0, e.g. due to the “Too many requests” type error.

    Paul

    Thanks for your help Paul. I’ve done a bit more digging using the Amazon Scratchpad, and it’s the ‘too many requests’ error from AWS. That seems unlikely, so I’m assuming the API has been blocked due to too few sales. I’ll get the site owner to check.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WordPress 5.1’ is closed to new replies.