Support » Plugin: Meow Gallery (+ Gallery Block) » WordPress (5.0-beta5-43933)

  • Resolved marbencz

    (@marbencz)


    I tried the plugin on two installation of WordPress (5.0-beta5-43933), but when the plug-in is activated, only a white blank screen is displayed in the administration. After plugin deactivating the page run fine. On version 4.9 everything works without any problem.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter marbencz

    (@marbencz)

    I tested plugin on WordPress 5.0-RC1-43944, PHP 7.1 and 7.2, but result is the same – white empty administration screen until I deleted plugin folder by ftp.

    Plugin Author Jordy Meow

    (@tigroumeow)

    Strange, it worked on my install. I am away from home and will be able to check this only Monday. Would you mind having a look at your PHP Error Logs? We will know exactly what’s happening with this.

    Thread Starter marbencz

    (@marbencz)

    Hi Jordy,
    the error (replaced full path with “web”):

    Fatal error: Uncaught Error: Call to undefined function gutenberg_get_jed_locale_data() in /web/wp-content/plugins/meow-gallery/mgl_blocks.php:26 Stack trace: #0 /web/wp-content/plugins/meow-gallery/mgl_blocks.php(10): Meow_Gallery_Blocks->backend_editor() #1 /web/wp-content/plugins/meow-gallery/mgl_core.php(17): Meow_Gallery_Blocks->__construct(Object(Meow_MGL_Admin)) #2 /web/wp-includes/class-wp-hook.php(286): Meow_Gallery_Core->init(”) #3 /web/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #4 /web/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #5 /web/wp-settings.php(467): do_action(‘init’) #6 /web/wp-config.php(95): require_once(‘/Users/marben/w…’) #7 /web/wp-load.php(37): require_once(‘/Users/marben/w…’) # in /web/wp-content/plugins/meow-gallery/mgl_blocks.php on line 26

    Plugin Author Jordy Meow

    (@tigroumeow)

    Oh, I see! Is Gutenberg enabled on your install?

    The plugin should work without it but maybe I made a mistake and Gutenberg became a dependency. Also, it could be rbe fact that the WP 5 beta is using a differ Gutenberg version than the latest Gutenberg, which is strange. I will investigate Monday.

    Thread Starter marbencz

    (@marbencz)

    I tried it with core WP 5 Gutenberg turned on and then with the Classic plugin plug-in. I tried it on a web host, then with myself on a local server, the result would always be the same.

    I can confirm this bug with Gutenberg Examples and the RC of WordPress 5.

    To make it happen, you need to have “turned off” the Gutenberg development plugin. Since WP5 is bringing it in, makes sense to turn off the development plugin.

    None the less, the function “wp_get_jed_locale_data”, what should have been added to core as stated here, is not present in core (or maybe it with another name).

    To prevent the error, one needs to activate the Gutenberg plugin. Or either copy the “gutenberg_get_jed_locale_data” function with a function_exists check.

    While it is then added back.

    Plugin Author Jordy Meow

    (@tigroumeow)

    Hi guys,

    Actually, this function was not required (yet) by the plugin, only if I include translations at some point in the future. As Gutenberg and WP 5 still in beta, I prefer not to include this yet, and I’ll add the i18n when WordPress is stable.

    I pushed a new version and it should work with all the versions. Please try it πŸ™‚

    Thread Starter marbencz

    (@marbencz)

    Hi Jordy,

    I currently have the version of WordPress 5.0-RC1-43947 and Meow Gallery 3.1.0 installed. I confirm that the Meow Gallery plugin can now be activated and works on a gallery inserted through the Classic Editor. Gallery created with Gutenberg remains unchanged.
    Thanks.

    Plugin Author Jordy Meow

    (@tigroumeow)

    Cool, @marbencz πŸ™‚ It works with Gutenberg as well, but you will need to switch to the Meow Gallery Block. You can do it from the standard Gallery Block, by using the “switch” icon (on the left of the topbar when you click on the gallery).

    Thread Starter marbencz

    (@marbencz)

    Hi Jordy,
    sorry, I misunderstood the plugin functionality in the Gutenberg editor. I already know πŸ™‚ Your plugin is even better than I originally thought :-))) Super job.
    If I finally use WordPress on a new site, I’m sure to buy a paid version.

    Plugin Author Jordy Meow

    (@tigroumeow)

    Super, I am glad you like the plugin @marbencz! πŸ™‚ Don’t hesitate to write a little review for it, it helps us a lot πŸ™‚

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘WordPress (5.0-beta5-43933)’ is closed to new replies.