Support » Plugin: WordPress Beta Tester » WordPress 5.0 Beta 4

  • Resolved Jeff Sterup

    (@foomagoo)


    My site will not update to WordPress 5.0 Beta 4. I have bleeding edge nightlies turned on but it won’t go past 4.9.9-alpha-43656.

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Andy Fragen

    (@afragen)

    Are you waiting for automatic updates or using the Update Now button?

    The other option might be to re-install 4.9.8, resave the bleeding edge nightlies option, and then use the Update Now button.

    I’m using the Update Now button and have tried resaving the bleeding edge nightlies option. I’ve also reinstalled wordpress and updated. Nothing gets me past 4.9.9 alpha.

    Plugin Author Andy Fragen

    (@afragen)

    Sorry, I’m not sure what else to try. The above works for me and most others have been able to update to the 5.0 branch by being on the bleeding edge nightly.

    is beta software. slow moves

    I clicked re-install 4.9.8 on the network updates page and it installed 4.9.8. I then deactivated and reactivated the beta tester plugin. Now I get this message at the top of the settings page for the beta tester plugin.

    “There are no development builds of the beta stream you have chosen available, so you will receive normal update notifications.”

    Plugin Author Andy Fragen

    (@afragen)

    Jeff, I wish I could replicate this. Can you try some stuff for me?

    Install the Query Monitor plugin.
    Make sure WordPress Beta Tester is activated and set to bleeding edge nightlies. I know, but I had to include it. 😉
    Go to the update-core.php page.
    You might need to reload the page a time or 2 but QM should see a few HTTP requests. Can you copy/paste those requests here?

    You should see a couple that start with https://api.wordpress.org/core/version-check/1.7/, those are the ones I’m looking for. The caller will be wp_beta_tester->filter_http_request()

    • This reply was modified 1 year, 7 months ago by Andy Fragen.
    • This reply was modified 1 year, 7 months ago by Andy Fragen.

    Here is the json response that was being returned when the update check was being performed in the filter_http_request function but it wasn’t recognizing that there was a beta version available. I went ahead and downloaded the beta version manually and installed it. I’m running the latest beta now.

    {"offers":[{"response":"development","download":"https:\/\/wordpress.org\/nightly-builds\/wordpress-5.0-latest.zip","locale":"en_US","packages":{"full":"https:\/\/wordpress.org\/nightly-builds\/wordpress-5.0-latest.zip","no_content":false,"new_bundled":false,"partial":false,"rollback":false},"current":"5.0-beta5-43909","version":"5.0-beta5-43909","php_version":"5.2.4","mysql_version":"5.0","new_bundled":"4.7","partial_version":false},{"response":"latest","download":"https:\/\/downloads.wordpress.org\/release\/wordpress-4.9.8.zip","locale":"en_US","packages":{"full":"https:\/\/downloads.wordpress.org\/release\/wordpress-4.9.8.zip","no_content":"https:\/\/downloads.wordpress.org\/release\/wordpress-4.9.8-no-content.zip","new_bundled":"https:\/\/downloads.wordpress.org\/release\/wordpress-4.9.8-new-bundled.zip","partial":false,"rollback":false},"current":"4.9.8","version":"4.9.8","php_version":"5.2.4","mysql_version":"5.0","new_bundled":"4.7","partial_version":false},{"response":"autoupdate","download":"https:\/\/wordpress.org\/nightly-builds\/wordpress-5.0-latest.zip","locale":"en_US","packages":{"full":"https:\/\/wordpress.org\/nightly-builds\/wordpress-5.0-latest.zip","no_content":false,"new_bundled":false,"partial":false,"rollback":false},"current":"5.0-beta5-43909","version":"5.0-beta5-43909","php_version":"5.2.4","mysql_version":"5.0","new_bundled":"4.7","partial_version":false,"new_files":true}

    Plugin Author Andy Fragen

    (@afragen)

    What was the actual HTTP Request?

    Here’s what mine looks like.

    https://api.wordpress.org/core/version-check/1.7/?version=5.1-wp-beta-tester&php=7.2.12&locale=en_US&mysql=5.6.40&local_package=&blogs=3&users=8&multisite_enabled=1&initial_db_version=36686

    • This reply was modified 1 year, 7 months ago by Andy Fragen.
    • This reply was modified 1 year, 7 months ago by Andy Fragen.

    I didn’t see your response until after I had responded and done the update manually. The request was similar to yours except the version was 5.0-wp-beta-tester.

    Plugin Author Andy Fragen

    (@afragen)

    This is what I see with bleeding edge nightlies and on 4.9.8

    https://share.icloud.com/photos/0bRZwJLXwNvdd9vcHZkb4MGrQ

    The only way I could figure out why it’s not working for you is to step through the code on your install. Sorry.

    The HTTP request should have 5.1-wp-beta-tester.

    • This reply was modified 1 year, 7 months ago by Andy Fragen.

    I’m still having this issue. I’m now running WordPress 5.0.3 and expecting to get WordPress 5.1 Beta 1. But it’s saying there are no updates available.

    Here is a screenshot of the query monitor output from the update-core.php page.

    http://www.jsterup.com/wp-content/uploads/2019/01/version-check.jpg

    Plugin Author Andy Fragen

    (@afragen)

    Jeff, it’s doesn’t really prompt you for updates. On the update-core.php page there should be a button “Update Now”.

    A screenshot of the entire update-core.php page would be helpful.

    It does appear that you are seeing the correct API calls.

    What I’m saying is that the update-core.php page says I’m already running the latest version.

    http://www.jsterup.com/wp-content/uploads/2019/01/update-core.jpg

    Printing the output from the filter_http_request functions gives me this.

    This is the URL it is calling: https://api.wordpress.org/core/version-check/1.7/?version=5.1-wp-beta-tester&php=7.2.13&locale=en_US&mysql=5.5.60&local_package=&blogs=4&users=2&multisite_enabled=1&initial_db_version=29630

    And this is the response:

    Array
    (
        [headers] => Requests_Utility_CaseInsensitiveDictionary Object
            (
                [data:protected] => Array
                    (
                        [server] => nginx
                        [date] => Thu, 17 Jan 2019 17:30:30 GMT
                        [content-type] => application/json; charset=UTF-8
                        [vary] => Accept-Encoding
                        [access-control-allow-origin] => *
                        [x-frame-options] => SAMEORIGIN
                        [content-encoding] => gzip
                    )
    
            )
    
        [body] => {"offers":[{"response":"development","download":"https:\/\/wordpress.org\/nightly-builds\/wordpress-latest.zip","locale":"en_US","packages":{"full":"https:\/\/wordpress.org\/nightly-builds\/wordpress-latest.zip","no_content":false,"new_bundled":false,"partial":false,"rollback":false},"current":"5.1-beta1-44629","version":"5.1-beta1-44629","php_version":"5.2.4","mysql_version":"5.0","new_bundled":"5.0","partial_version":false},{"response":"latest","download":"https:\/\/downloads.wordpress.org\/release\/wordpress-5.0.3.zip","locale":"en_US","packages":{"full":"https:\/\/downloads.wordpress.org\/release\/wordpress-5.0.3.zip","no_content":"https:\/\/downloads.wordpress.org\/release\/wordpress-5.0.3-no-content.zip","new_bundled":"https:\/\/downloads.wordpress.org\/release\/wordpress-5.0.3-new-bundled.zip","partial":false,"rollback":false},"current":"5.0.3","version":"5.0.3","php_version":"5.2.4","mysql_version":"5.0","new_bundled":"5.0","partial_version":false},{"response":"autoupdate","download":"https:\/\/wordpress.org\/nightly-builds\/wordpress-latest.zip","locale":"en_US","packages":{"full":"https:\/\/wordpress.org\/nightly-builds\/wordpress-latest.zip","no_content":false,"new_bundled":false,"partial":false,"rollback":false},"current":"5.1-beta1-44629","version":"5.1-beta1-44629","php_version":"5.2.4","mysql_version":"5.0","new_bundled":"5.0","partial_version":false,"new_files":true}],"translations":[]}
        [response] => Array
            (
                [code] => 200
                [message] => OK
            )
    
        [cookies] => Array
            (
            )
    
        [filename] => 
        [http_response] => WP_HTTP_Requests_Response Object
            (
                [response:protected] => Requests_Response Object
                    (
                        [body] => {"offers":[{"response":"development","download":"https:\/\/wordpress.org\/nightly-builds\/wordpress-latest.zip","locale":"en_US","packages":{"full":"https:\/\/wordpress.org\/nightly-builds\/wordpress-latest.zip","no_content":false,"new_bundled":false,"partial":false,"rollback":false},"current":"5.1-beta1-44629","version":"5.1-beta1-44629","php_version":"5.2.4","mysql_version":"5.0","new_bundled":"5.0","partial_version":false},{"response":"latest","download":"https:\/\/downloads.wordpress.org\/release\/wordpress-5.0.3.zip","locale":"en_US","packages":{"full":"https:\/\/downloads.wordpress.org\/release\/wordpress-5.0.3.zip","no_content":"https:\/\/downloads.wordpress.org\/release\/wordpress-5.0.3-no-content.zip","new_bundled":"https:\/\/downloads.wordpress.org\/release\/wordpress-5.0.3-new-bundled.zip","partial":false,"rollback":false},"current":"5.0.3","version":"5.0.3","php_version":"5.2.4","mysql_version":"5.0","new_bundled":"5.0","partial_version":false},{"response":"autoupdate","download":"https:\/\/wordpress.org\/nightly-builds\/wordpress-latest.zip","locale":"en_US","packages":{"full":"https:\/\/wordpress.org\/nightly-builds\/wordpress-latest.zip","no_content":false,"new_bundled":false,"partial":false,"rollback":false},"current":"5.1-beta1-44629","version":"5.1-beta1-44629","php_version":"5.2.4","mysql_version":"5.0","new_bundled":"5.0","partial_version":false,"new_files":true}],"translations":[]}
                        [raw] => HTTP/1.1 200 OK
    Server: nginx
    Date: Thu, 17 Jan 2019 17:30:30 GMT
    Content-Type: application/json; charset=UTF-8
    Transfer-Encoding: chunked
    Connection: close
    Vary: Accept-Encoding
    Access-Control-Allow-Origin: *
    X-Frame-Options: SAMEORIGIN
    Content-Encoding: gzip
    
    {"offers":[{"response":"development","download":"https:\/\/wordpress.org\/nightly-builds\/wordpress-latest.zip","locale":"en_US","packages":{"full":"https:\/\/wordpress.org\/nightly-builds\/wordpress-latest.zip","no_content":false,"new_bundled":false,"partial":false,"rollback":false},"current":"5.1-beta1-44629","version":"5.1-beta1-44629","php_version":"5.2.4","mysql_version":"5.0","new_bundled":"5.0","partial_version":false},{"response":"latest","download":"https:\/\/downloads.wordpress.org\/release\/wordpress-5.0.3.zip","locale":"en_US","packages":{"full":"https:\/\/downloads.wordpress.org\/release\/wordpress-5.0.3.zip","no_content":"https:\/\/downloads.wordpress.org\/release\/wordpress-5.0.3-no-content.zip","new_bundled":"https:\/\/downloads.wordpress.org\/release\/wordpress-5.0.3-new-bundled.zip","partial":false,"rollback":false},"current":"5.0.3","version":"5.0.3","php_version":"5.2.4","mysql_version":"5.0","new_bundled":"5.0","partial_version":false},{"response":"autoupdate","download":"https:\/\/wordpress.org\/nightly-builds\/wordpress-latest.zip","locale":"en_US","packages":{"full":"https:\/\/wordpress.org\/nightly-builds\/wordpress-latest.zip","no_content":false,"new_bundled":false,"partial":false,"rollback":false},"current":"5.1-beta1-44629","version":"5.1-beta1-44629","php_version":"5.2.4","mysql_version":"5.0","new_bundled":"5.0","partial_version":false,"new_files":true}],"translations":[]}
                        [headers] => Requests_Response_Headers Object
                            (
                                [data:protected] => Array
                                    (
                                        [server] => Array
                                            (
                                                [0] => nginx
                                            )
    
                                        [date] => Array
                                            (
                                                [0] => Thu, 17 Jan 2019 17:30:30 GMT
                                            )
    
                                        [content-type] => Array
                                            (
                                                [0] => application/json; charset=UTF-8
                                            )
    
                                        [vary] => Array
                                            (
                                                [0] => Accept-Encoding
                                            )
    
                                        [access-control-allow-origin] => Array
                                            (
                                                [0] => *
                                            )
    
                                        [x-frame-options] => Array
                                            (
                                                [0] => SAMEORIGIN
                                            )
    
                                        [content-encoding] => Array
                                            (
                                                [0] => gzip
                                            )
    
                                    )
    
                            )
    
                        [status_code] => 200
                        [protocol_version] => 1.1
                        [success] => 1
                        [redirects] => 0
                        [url] => https://api.wordpress.org/core/version-check/1.7/?version=5.1-wp-beta-tester&php=7.2.13&locale=en_US&mysql=5.5.60&local_package=&blogs=4&users=2&multisite_enabled=1&initial_db_version=29630
                        [history] => Array
                            (
                            )
    
                        [cookies] => Requests_Cookie_Jar Object
                            (
                                [cookies:protected] => Array
                                    (
                                    )
    
                            )
    
                    )
    
                [filename:protected] => 
                [data] => 
                [headers] => 
                [status] => 
            )
    
    )
    Plugin Author Andy Fragen

    (@afragen)

    Now I see what you mean.

    Can you disable all other plugins and return to a default theme. Then re-save the Bleeding edge nightlies setting.

    Then show me a screenshot.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘WordPress 5.0 Beta 4’ is closed to new replies.