Support » Fixing WordPress » WordPress 4.6 Tools – Export Missing

  • Hi,

    I’m logged in as Admin user in my WordPress 4.6 site.

    Under Tools I can see (actually I activated it) the Import option.

    But the Export is not there. Even more, I installed the “WordPress Exporter” that replace the option in the menu. Still not there.

    Going to http://<mysite>/wp-admin/export.php will show an error page with message “Sorry, you are not allowed to access this page.

    Does anyone have an idea what can be happening?

    Thanks in advance,
    Omar

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator πŸš€

    What is the URL of the actual site?

    Is it part of a Multisite Network, or is it a single site installation?

    I am having exactly the same issue as ovillasmil..2017.06.27

    I cannot see the Export option in Tools

    I am logged in as an Administrator in my WordPress 4.8 website. This is a single site installation. (It is a private site or I would give the URL)

    Under Tools I can see the Import option, but the Export is not there.

    Going to http://<mysite>/wp-admin/export.php will show an error page with message β€œSorry, you are not allowed to access this page.β€œ

    I have created a new Administrator user account, and the problem persists. I deactivated all plugins, problem persists. I reinstalled WordPress version 4.8, problem persists. Restarted the website, problem persists.

    Can anyone help with the next thing to try. We depend on the Export function to get weekly copies of all the website content, to be ready to quickly set up a new site in case of failure.

    • This reply was modified 9 months, 4 weeks ago by  karendean.

    Having just had a similar issue, I restored the missing option by adding this to functions:

    
    $admin_role = get_role( 'administrator' );
    $admin_role->add_cap( 'export', true );
    

    And now, even when that code is commented-out, ‘export’ is available.

    Thank you gulliver – I’m noting this for future websites!

    It was a dev/testing site that I had the problem on, and have no idea what caused it. Now I at least have a solution to try when/if it happens again. (I deleted the problem dev website. I cloned a new dev site from the prod site, so I can’t test your solution on that ‘broken’ website.)

    @karendean… I’m glad if it’s helped.
    It seems an odd issue, and I don’t suppose I’ll discover the cause. πŸ˜‰

    Quick update, for clarification…

    The (albeit unexplained) cause of this issue is that the capabilities (https://codex.wordpress.org/Roles_and_Capabilities) of the user have been changed (but by what, we don’t know).

    The code snippet in my earlier post adds a capability (albeit one which should already be there) to the admin role, and thus restores the ‘export’ option.

    @gulliver … strange happenings! Thank you AGAIN for following thru on this … as you allude to, I don’t know what would have changed the administrator role/capabilities on the website – but now you’ve given light on how to reset the ‘fault’.

    Well done! Thank you…

    @karendean… thanks.

    After many years of ‘hhhmmm… strange’, I’m learning to accept that ‘stuff just happens’ and I’m grateful that for much of the time most things work as they should… and when they don’t, then it’s probably an hour or a day searching for a fix – for which I’ve had so much help from others that I’m happy to be able to share what little I can. πŸ™‚

    reneequinn

    (@reneequinn)

    Had the same problem today. I couldn’t get Duplicator working. Tried this and all fixed.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘WordPress 4.6 Tools – Export Missing’ is closed to new replies.