Support » Fixing WordPress » WordPress 4.6 has caused significant issues.

  • After installing WordPress 4.6 last night the update has caused numerous issues that make it virtually impossible to get posts completed and ready to be published. My Wife and I run a Anime Review website where we provide double sided reviews. We each work together on articles, trading the post draft back and forth, in order to create our content.

    Firstly: When saving drafts and then leaving them, we find that wordpress still claims one of the two of us is accessing the draft. When we try to wrestle control back (when it asks you to take control of the post) nothing happens and the pop up, warning you that someone is still editing the draft, remains. It takes several attempts and, assuming it ever works, we find that the draft is not the current one.

    Sometimes this can be resolved simply by refreshing the page, sometimes not.

    If I go to make another drafted post shortly after, it overwrites the previous drafted post, even if the two aren’t named anything similar.

    I have tried clearing our Browser Caches to no avail. I have tried Purging the Varnish to no avail. I have tried disabling all the plug ins. The plug ins page also does not update correctly. It will show the plug ins still active for sometime, unless I hit refresh and then it’ll show that all plug ins (Save Wordfence for security reasons) are deactivated properly. So, I guess all the plugins are now off?

    Even changing the theme to the 2016 default had little effect. Entering posts and editing them, then saving the draft yields the same frustrating results. when going back into posts the edits aren’t immediately apparent. I have to again refresh the page to get any of the changes to show up properly. However, changing the theme did cause the new ‘format’ tab on the right to display, so I guess there’s that.

    I’m at a loss for how to proceed and exceedingly frustrated as this has killed an entire days worth of work. Any help would be most appreciated as AllYourAnime.Net simply can’t run like this as it is.

    -Tom

Viewing 15 replies - 1 through 15 (of 17 total)
  • Thread Starter allyouranime

    (@allyouranime)

    Update:

    I’ve attempted to pinpoint/better describe exactly what the issue is. I think it’s a caching issue on the backend.

    I can revise posts (by myself, I haven’t tried letting my wife log in and us swap between posts yet) and it’ll tick the Revision number up. However, if I enter the post again a second time it won’t recognize the new revision right away (Let’s say I save and it marks it as Revision 14, when I enter back in it’ll still be 13) until I refresh the page.

    This goes for Plug ins too. I can deactivate plug ins, but it won’t immediately tick them as off, not until I refresh the page.

    After backing up my site again, I’ve deactivated all the plug ins, deleted every plug in we hadn’t been using anyway, and when that didn’t fix it I turned on plug ins that are listed as 4.6 compatible for sure.

    This makes me think it’s a weird kind of backend caching issue (<– total newb here) that’s causing the backend to not properly refresh and immediately display the most recent changes.

    Again, any help would be appreciated as we’re losing a lot of work time having to deal with this. =/

    What other plugins do you have enabled on that site ?

    Thread Starter allyouranime

    (@allyouranime)

    Right now I’ve only got Child Theme Editor, Wordfence, and Yoast turned on, as they’re listed as 4.6 Compatible.

    What’s turned off currently, but not deleted are: Disqus Conditional Load, Google AdSense, Insert Headers and Footers, Patreon Button, Post Views Counter, Varnish HTTP Purge, and W3 Total Cache (although this has always remained off since a caching bug when we first launched the website back in March)

    Everything listed there has yet to be marked as compatible with 4.6, so I thought maybe it was one of them, but after having been off for several hours there’s no change.

    Thanks for the help btw,
    -Tom

    I’ve been having the same exact issues as well. I too thought it was a caching issue, so disabled W3TC plugin + suspended transients, but it’s still doing the same thing.

    running PHP 5.6.22 on a 64BitOS

    Similar problem for me.

    In various sites, I need to refresh the page to see the changes made. Even in development sites which don’t have any caching plugin.

    Running on PHP 7.0.9, ‪CentOS 6.6.

    I am also running CentOS 6.8, Apache/2.2.15 (Red Hat)

    @allyouranime

    Which web browser have you been using?

    Or does the same issue happen in Google Chrome and Mozilla Firefox?

    Thread Starter allyouranime

    (@allyouranime)

    I’ve accessed the site through both Chrome and Safari (don’t use/have Firefox) and either browser suffered the same issue.

    I found the solution (at least, for me)!

    It was an Expire Headers issue. The Nginx directive was bad.

    This is the old directive:

    expires 24d;

    and this is the new one:

    location ~* \.(?:ico|css|js|gif|jpe?g|png)$ {
    	expires 24d;
    }

    which tells the browser to cache only the files with the specified extensions.

    If you are using only Apache, without Nginx, adding the following line to your “.htaccess” file should solve the issue, but I didn’t test it:

    #Expire Header
    <FilesMatch "\.(ico|jpg|jpeg|png|gif|js|css)$">
    ExpiresDefault "access plus 24 days"
    </FilesMatch>

    If the website is not showing, just remove the lines.

    Hope it helps!

    Thread Starter allyouranime

    (@allyouranime)

    Hey Pacicio, complete newbie here:

    So our website’s servers and such are run by pair. How would I go about making these changes myself or do I need to direct Pair’s tech support to this potential solution?

    Thanks,
    -Tom

    Like he said, add it to your .htaccess file.

    Thread Starter allyouranime

    (@allyouranime)

    Yeah and like I said, I don’t really know how to do that.

    Google it…it’s pretty straight forward.

    I turned on debugging mode in the wp-config file to see if there were errors, but there were none. Strangely everything seemed to work normal again even after turning debugging off again.

    The “.htaccess” file is in the root of your site: you can access and modify it using an FTP Client or the File Manager of your hosting service.

    The code I posted before should fix the issue.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘WordPress 4.6 has caused significant issues.’ is closed to new replies.