Support » Fixing WordPress » WordPress 4.5 Translations Won't "Stay" Updated

  • After running WordPress 4.4 without issue after a clean install for a few months, 4.5 just came out. It updated via the admin just fine as have all the plugins offering updates. Translations also updated fine. However every time I hit the “refresh” updates button or log in, the Translations show there’s an update available again. I’ve updated them without issues at least 10 times now and each time the fact that it has updated them won’t stick. Any thoughts?

    Thanks in advance,
    Derya

Viewing 7 replies - 1 through 7 (of 7 total)
  • I’m having the same issue — after a long “translations update” with an indication that “Translation updated successfully & All updates have been completed” — the Dashboard Updates indicator continues to indicate that a new translation is available. When attempted, the above is repeated again with “updated successfully” results and Groundhog Day all over again.

    I have the same issue… since I host an “Alien” SubSite with alien language for the alien-band of a friend I wonder if this is related…

    Moderator Dominik Schilling

    (@ocean90)

    WordPress Core Developer

    Hello, can you provide some more infomation about your install? Which language are you using? Which plugins are enabled and which theme are you using? Can you see which translation gets updated?

    Same problem here. Thought Jetpack or W3 Total Cache might be the culprit, but I disabled all plugins and the translations still won’t stay updated. Using the Avada theme.

    It probably has something to do with permissions or ownership but I don’t know what they should be or how to resolve it.

    Hello, me too I have the same problem with some plugins.
    Wordpress continously says New translations are available, even if I update translations.
    For what I see, WordPress downloads new .po and .mo files in /wp-content/plugins , but than files remains there, instead of complete update.

    Can you help me please?

    Same problem here – were any of you able to find a solution?
    Wordpress 4.5.3 , Enfold theme – translations being updated are for wordpress and woocommerce.

    This irritated me for 6 months. I finally found a solution that works: go to your wp-content directory and rename /wp-content/languages to /wp-content/languages-old. Simple as that. You can probably delete the languages-old directory after a week or so.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WordPress 4.5 Translations Won't "Stay" Updated’ is closed to new replies.