Support » Fixing WordPress » WordPress 4.5 error after update !

  • Resolved tmt2012

    (@tmt2012)


    I get message after update wordpress. Please help me.
    Fatal error: Class ‘WP_Metadata_Lazyloader’ not found in /home/minhtamblog.com/public_html/wp-includes/meta.php on line 865

Viewing 15 replies - 1 through 15 (of 19 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    Try manually reinstalling the WP files.

    elfatrany

    (@elfatrany)

    Hi there,

    I have the same exact error and the manually updating WP does not work.

    Any ideas?

    salj42

    (@salj42)

    Same error, manually reinstalling WP does nothing for me either, neither did disabling plugins. This seems to be the only thread about this showing up in google.

    salj42

    (@salj42)

    Hey, I found the fix. After adding require( ABSPATH . WPINC . '/class-wp-metadata-lazyloader.php' ); to wp-settings.php everything seems to be working again.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    The wp-settings.php file already contains that line. You don’t need to add it by hand.

    When we say to “manually reinstall”, we do mean that. As in, actually replace the files on the server with the correct ones. The wp-settings.php file in WordPress 4.5 changed. If you did only a partial installation, and did not update ALL the files, including those in the root directory, like wp-settings.php, then yeah, your site will remain broken.

    MANUALLY UPDATE ALL THE FILES. That will fix this problem.

    mkmpvtltd

    (@mkmpvtltd)

    hi there i have fixed my site instruction given by salj42 but when i want to access wp-admin there is problem like css not loaded(Page without design)?

    monica

    (@monilou)

    Not sure if I should start a new thread?? After I updated to wordpress 4.5 I am getting this error:
    1) add_object_page is deprecated since version 4.5! Use add_menu_page() instead. in /nfs/c08/h06/mnt/116264/domains/savonsupplements.com/html/wp-includes/functions.php on line 3662

    And

    2) Warning: Cannot modify header information – headers already sent by (output started at /nfs/c08/h06/mnt/116264/domains/savonsupplements.com/html/wp-includes/functions.php:3662) in /nfs/c08/h06/mnt/116264/domains/savonsupplements.com/html/wp-includes/pluggable.php on line 1171

    Everything on my test website is updated and the wordpress update is the only change I made. Apologies if this is supposed to be a new thread!

    Thanks for any help! I am a newbie at this stuff so not sure what to do? Should I manually update wordpress? Can you provide some advice about how to do this?

    Monica

    monica

    (@monilou)

    Hi there!

    I have manually re-installed the functions.php file from WP 4.5 and I’m getting the same error:

    add_object_page is deprecated since version 4.5! Use add_menu_page() instead. in /nfs/c08/h06/mnt/116264/domains/savonsupplements.com/html/wp-includes/functions.php on line 3662

    All my plugins are updated. If anyone has suggestions, I’ll try it! Thanks in advance everyone!

    Monica

    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    Make sure to create a new thread to discuss your own issues: https://wordpress.org/support/forum/how-to-and-troubleshooting#postform

    azn137

    (@azn137)

    I can confirm that overwriting the wp-settings.php file from a fresh 4.5 zip file fixes this. WTF?

    mikeill

    (@mikeill)

    I can confirm that overwriting the wp-settings.php file from a fresh 4.5 zip file fixes this.

    Fixed it for me, too. Not sure why the updater didn’t add the new wp-settings.php file.

    sabweb

    (@sabweb)

    Yes, the settings.php fixed it

    Wale

    (@wtoalabi)

    Same here! Overwriting worked!

    martinsukerphotography

    (@martinsukerphotography)

    My error states – Notice: get_currentuserinfo is deprecated since version 4.5! Use wp_get_current_user() instead. in /hermes/bosnaweb03b/b1170/ipg.martinsukerphotograp/MSP_WP/wordpress/wp-includes/functions.php on line 3662 Notice: get_currentuserinfo is deprecated since version 4.5! Use wp_get_current_user() instead. in /hermes/bosnaweb03b/b1170/ipg.martinsukerphotograp/MSP_WP/wordpress/wp-includes/functions.php on line 3662

    how do i fix this?

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    @martinsukerphotography Turn off the WP_DEBUG setting in your wp-config.php file.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘WordPress 4.5 error after update !’ is closed to new replies.