Support » Fixing WordPress » WordPress 4.3 – How to disable Formatting Shortcuts?

  • Let’s say I actually need to enter ## without it being converted to a heading? Or > without WordPress formatting the text after it into a block quote? How do I disable this automatic reformatting?

Viewing 4 replies - 1 through 4 (of 4 total)
  • I think you can just press ESC or CMD/CTRL Z or click the undo-button in those cases.

    Wow, I can’t believe that it’s just not an option to turn off. Is there anything in the API that can change it?

    Moderator keesiemeijer

    (@keesiemeijer)

    The shortcut for ## or > is only converted if you hit enter. Hit esc after it to not convert the ## or > (or click somewhere else in the editor).

    If you really want to disable it you can use this in your (child) theme’s functions.php file.

    function disable_mce_wptextpattern( $opt ) {
    
    	if ( isset( $opt['plugins'] ) && $opt['plugins'] ) {
    		$opt['plugins'] = explode( ',', $opt['plugins'] );
    		$opt['plugins'] = array_diff( $opt['plugins'] , array( 'wptextpattern' ) );
    		$opt['plugins'] = implode( ',', $opt['plugins'] );
    	}
    
    	return $opt;
    }
    
    add_filter( 'tiny_mce_before_init', 'disable_mce_wptextpattern' );

    btw:
    consider creating a child theme instead of editing your theme directly – if you upgrade the theme all your modifications will be lost. Or create a plugin with the code above.

    Moderator Marius L. J.

    (@clorith)

    You can remove it with a filter if you so desire 🙂

    The filter you want to hit is tiny_mce_plugins, removing wptextpattern from the array you get access to then would remove the shortcut functionality.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘WordPress 4.3 – How to disable Formatting Shortcuts?’ is closed to new replies.