Support » Fixing WordPress » WordPress 4.0 Upgrade broke TinyMCE Visual Editor

  • Recently, updated our website to WordPress 4.0 and now the visual editor, TinyMCE, no longer works. I can only edit posts/pages in HTML and cannot add media. Looking at the Chrome JavaScript Console, I get

    Uncaught SyntaxError: Unexpected token ILLEGAL
    plugin.min.js:1 Uncaught ReferenceError: tinymce is not defined
    post-new.php:2427 Uncaught ReferenceError: tinymce is not defined
    wp-langs-en.js:235 Uncaught ReferenceError: tinyMCE is not defined
    post-new.php:2421 Uncaught ReferenceError: tinymce is not defined
    load-scripts.php:50 Uncaught TypeError: Cannot read property 'top' of undefined

    I have tried disabling all plugins, changing the theme to twenty-fourteen and still have the error. I have tried different browsers and to no avail. I have cleared cache. These were all tips from other posts that I have found. Where do I go next

Viewing 7 replies - 1 through 7 (of 7 total)
  • Same here! I have no clue what to try next…

    I have the same problem, I can’t seem to use the visual editor and even the text editor only works sometimes. I’ve tried the above also, not sure what else I can do.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    I have cleared cache

    Are you using *any other form* of caching? Are you using CloudFlare? Things like that can affect your view of the site as well.

    Clearing cache can be tricky sometimes, but it has to be done after an upgrade.

    Thread Starter bx01z

    (@bx01z)

    No, I don’t have any form of caching or CloudFare. I even tried adding the “Use Google Libraries” plugin that someone suggested in another post and that didn’t fix any issue.

    Does anyone else have ideas on where to go next with this or how to find the source of the bug.

    Does anyone know how to resolve this issue? Same thing has happened to me and can’t find anyway to fix it,

    I get atleast 20 of these types of errors in the chrome JavaScrpit Console:

    "Failed to load: http://www.i-ras.co.uk/wp-content/plugins/tinymce-advanced/mce/searchreplace/plugin.min.js"

    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    @mhbaynham, Open a thread on your problematic plugin’s support section of the forum: https://wordpress.org/support/plugin/tinymce-advanced#postform

    You should always create a thread to discuss your own issues.

    Try adding define(‘SCRIPT_DEBUG’, true);to the bottom of your wp-config.php file (just before the require_once line).

    Someone wrote that in another thread and after horrendous nights of trying to figure this out that did the trick for me!!!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WordPress 4.0 Upgrade broke TinyMCE Visual Editor’ is closed to new replies.