Support » Fixing WordPress » WordPress 4.9 Media Element “Live Broadcast”

  • Hi,

    Since upgrading to wordpress 4.9 the time rail on the audio player simply displays “Live Broadcast” instead of a time rail when you press play. (If you don’t see it in the page example its because the colour of .mejs-broadcast is white – check the page source).

    On my local machine also running wordpress 4.9 this doesn’t happen.

    I’m baffled why the remote version of the site thinks this is a “Live Broadcast”?

    Can anyone shed some light on this?

    Thanks

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator Steven Stern (sterndata)

    (@sterndata)

    Support Volunteer

    The audio stuff works normally on my sites, so it’s probably something with yours.

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    Hi Steve,

    I’ve tried all of that. I switched theme to twenty seventeen and the players don’t work at all, never mind showing “Live Broadcast”. I see lots of Javascript errors only in safari: Unhandled Promise Rejection: [object DOMError] (I’m seeing the problem in safari, chrome and firefox though)

    Like I said, no problems on my local machine running WP 4.9 so I think this problem has something to do with the server environment. The most infuriating thing is googling “Live Broadcast” together with any wordpres or media element terms yields no relevant results – seems I am the only person in the world seeing the words Live Broadcast displayed on my audio player but I didn’t put them there…

    Also, this problem has only started since upgrading wordpress to 4.9. It’s the first upgrade issue I’ve had with any wordpress site for years that wasn’t easily fixable! But it seems like the changes to mediaelement.js in WordPress 4.9 have broken something.

    I even get the same behaviour when playing track in the wordpress editor so I know there’s nothing wrong with any front end code!

    It’s bizarre, this is not a Live Broadcast!!! It’s just an mp3!

    • This reply was modified 11 months, 4 weeks ago by  ralphonz.
    • This reply was modified 11 months, 4 weeks ago by  ralphonz.
    Moderator Steven Stern (sterndata)

    (@sterndata)

    Support Volunteer

    Hmm… I don’t see that at all. (I like that Michael Lion track!) I see a normal player bar.

    The Dave Cook track plays normally for me, but not The Whippet Beans. I suspect that there may be something in how the tracks are encoded.

    Also, the files are being served from a CloudFLare cache, which may be why it’s interpreted as a stream in a HTML5 player as HTML5 would be able to interpret the strea mheaders (whcih the old methods did not neccesarely support). You don’t use Cloudflare when playing locally.

    Try clearing the cache on Cloudflare or, temporarily, removing it from the configuration to see if that helps.

    (Props to Clorith for the CloudFlare suggestion!)

    Hi Steve,

    Thanks for your reply, it was helpful in me tracking down the issue further but I’ve ended up even more confused!!

    Firstly, I have another site on the same server, also using cloudflare and there’s no problems there, i.e. it shows the length of the files, not “Live Broadcast”. See here. For this reason I don’t think it’s a cloudflare issue (I have checked the settings are almost identical for each site). Server settings in cPanel look the same for each site too. I’ve tried emptying the cloudflare cache, server cache and browser cache but have had no luck.

    It’s odd that the Dave Cook track always plays for you but not the whippet beans, all the mp3’s have been encoded in the exact same way in my studio.

    All the tracks play fine for me, I can hear the audio, except the total time and progress is not displayed – in Safari and Chrome. In firefox the total time and progress is displayed but constantly changes (i.e. it grows) and so the progress of the bar doesn’t work as it should – it’s hard to describe but you can take a look.

    Further inspection of the markup in safari and chrome shows the attribute aria-valuemax as “NaN”. I assume this means that the html can’t read the headers as you suggested but why and how to fix it? Said markup aria-valuemax doesn’t;t exist on Firefox apparently adding further mystery! Also this isn’t happening on my other site with audio players.

    I’m willing to take anything anyone can throw at me at this stage, feel like I’m loosing my mind…

    • This reply was modified 11 months, 3 weeks ago by  ralphonz.

    I figured it out so thought I’d share my findings here in case anyone else has a similar issue.

    Basically it’s because of GZIP, as media files are already compressed. I disabled GZIP compression for mp3 files using .htaccess:

    SetOutputFilter DEFLATE
    SetEnvIfNoCase Request_URI \.mp3$ no-gzip dont-vary

    And that fixed the issue! Advice for this came after speaking to cloudflare and my web host.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WordPress 4.9 Media Element “Live Broadcast”’ is closed to new replies.