Support » Plugin: SVG Support » WordPress 4.9.2 Update – SVG Not working

  • Resolved CarolBEB

    (@carolbeb)


    First, thank you for this easy to use plugin! Unfortunately, it appears the recent WP update may have caused a problem. The SVG on the referenced page is no longer working. Any ideas?
    Thank you, -c

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Benbodhi

    (@benbodhi)

    Hi there,

    My pleasure! Thanks for using my plugin.

    It’s hard to tell exactly, but you have mixed content warnings… They may have an impact.

    I assume you mean it isn’t rendering the SVG inline? Because I can see the actual SVG map.

    I just downloaded your SVG map and tested on my dev/testing site which is running WP 5.0-alpha-42492. It seems to inline ok.

    Please provide more info for me to understand what you are experiencing.

    Hi and thank you for such a quick response!

    You are correct the map is showing but the areas are no longer recognizing the links to their respective pages any more.

    I am not sure what you mean by “mixed content warnings”

    Apologies for not using proper terms… I am not that savvy 🙂

    • This reply was modified 3 months, 1 week ago by  CarolBEB.
    Plugin Author Benbodhi

    (@benbodhi)

    The mixed warnings are to do with SSL. You have some resources being called over http while using https. You need to make sure all of your site content is calling over https:// or just relative using // alone.

    I don’t think that would affect it, but it’s something you should do anyway.

    It’s hard to tell what the issue would be and why it would work and now not. Have you updated the theme? Maybe try testing with the default twentyseventeen theme.

    With default WP, my plugin and your SVG, it works fine. So it must be your theme or another plugin, or the way it is implemented in the page. It looks like you have it in a text widget, which usually works fine.

    Thank you! I check on the http/https. I know this isn’t why you are responding… but, I’ll ask anyway… as is the saying, “it never hurts to ask” 🙂 I am not sure how to make the paths relative in WordPress… is that something you could share? This is something that I wished could be done, but didn’t know it could be done in WordPress.

    I will test the plugins as there were a couple of updates for those.

    Thank you, again, for such prompt replies!

    Plugin Author Benbodhi

    (@benbodhi)

    It really depends on each and every implemented link. Some you won’t be able to and others, like when you embed into a page/post/widget you can do it just by leaving the leading http/https off.

    1. With https:
    <img src="https://yoursite.com/your-image.svg" />

    2. With relative:
    <img src="//yoursite.com/your-image.svg" />

    As for the issue at hand. For testing, the easiest way is to disable the rest of the plugins and revert to default theme, then reactivate one by one, testing in between until you find which one causes the issue.

    And if it isn’t working with default theme and all other plugins deactivated we can go from there.

    • This reply was modified 3 months, 1 week ago by  Benbodhi.
    CarolBEB

    (@carolbeb)

    Thank you for the info about relative paths and WordPress!

    I will sort through the plugins (on/off) and let you know what I find out.

    Much appreciation!
    -c

    Plugin Author Benbodhi

    (@benbodhi)

    My pleasure. Hopefully you get it sorted. Happy to help if you need further assistance.

    CarolBEB

    (@carolbeb)

    Hello – after trying the following: Change theme (to twenty seventeen) and deactivating plugin one by one… the problem didn’t resolve…

    So, I decided to try another approach… I recreated the svg file (map w/links), uploaded and replaced the previous one. It is now working!

    Only thing I can think of is that the update stripped the coding from the original svg file…not sure if this is possible, but it’s the only thing I can think of 🙂

    Thank you for your plugin and especially for your excellent help!
    -c

    Plugin Author Benbodhi

    (@benbodhi)

    Good news. Glad you got it sorted. And I’m always happy to help.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.