Support » Fixing WordPress » WordPress 4.8 Page Editor Does Not Work (Visual or Text)

  • Resolved bdunnewald7

    (@bdunnewald7)


    I have a site (bryandunnewald.com) using Thesis and a GoDaddy server. I recently upgraded to WordPress 4.8 and when trying to edit page text, the editor doesn’t show any text or edit options. The text is still there (it appears on the site) and is even editable, but only if I highlight a random section searching for what I need. Once I find it, I can edit but not see what I’m typing. It’s as if the editor were stuck in Text mode (no visual) and the editor only displays in white text, only appearing against the white background of the editor (not the actual site) when highlighted.

    I have updated all plugins and themes, have emptied the browser cache (I use Safari) and tried it in Firefox too. I have disabled all plugins and tried the error console. All this to no avail. Any help is greatly appreciated!
    Thanks,
    bdunnewald7

Viewing 15 replies - 1 through 15 (of 18 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Just to be sure, make sure that you have tried deactivating *all* plugins, even ones you feel are essential. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the Twenty Seventeen theme to rule-out a theme-specific issue (theme functions can interfere like plugins).

    Yes indeed – just tried both again to be sure and still no luck.

    Here is an image of what I’m talking about: http://bryandunnewald.com/wp-content/uploads/2017/06/Screen-Shot-2017-06-21-at-5.50.36-PM.png

    • This reply was modified 2 years, 7 months ago by bdunnewald7.
    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    This is rather odd, normally this is caused by a function conflict or an editor style.

    Would you mind sending over a screenshot of it with no plugins active and using Twenty Seventeen? I’m curious if anything changes, even just slightly.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Ok, I just noticed in both screenshots that the editor’s toolbar is completely missing too. That’s fun.

    Are you using any sort of caching plugin, or do you see a “Clear/Purge Cache” button in your Dashboard somewhere? If so, would you please try clearing the cache?

    Note: You do not need to install a caching plugin at this point just to clear a cache you don’t have.

    If you can’t running any caching system, or clearing it made no difference, Try adding define('CONCATENATE_SCRIPTS', false); to your wp-config.php file just below the define('DB_HOST' line.

    To do so, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, and edit the file with a plain text editor.

    https://codex.wordpress.org/Editing_wp-config.php#Disable_Javascript_Concatenation

    Tried clearing the cache again with no luck, but the “define…” script worked! Is this a permanent fix or do we need to do anything further? Thanks!

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Yes, it’s a decent permanent fix.

    WordPress tries to load all of your JavaScript at once to improve performance, but sometimes when you add in plugins, themes, and sever resource limitations, the combined JavaScript becomes too much for it to handle.

    What you did above is disable that combination, so some day you may be able to enable it again, but there’s really no need. As long as it works. ๐Ÿ™‚

    Thanks for your help!

    I have the exactly same problem, but it does not get fixed with “define” script.

    Any help?

    Same issue with me but did not get fix with โ€œdefineโ€ script.
    I’ve tried all other options as well.

    I gave up and rolled back to earlier 4.7.5 version ๐Ÿ™

    I updated to WordPress 4.8 and both the Visual Editor and Text Editor tabs are missing. I can only see html when trying to edit a page. I tried the Concatenate script but of course it didn’t work for me. I have disabled all plugins and even tried switching the theme which caused an additional headache which you (and others) did not mention. If you change your theme be aware that when you switch back to your original theme you most likely will have to rebuild parts of your site if you are using certain plugins. I use a sidebar plugin which lost all of its widgets after I switched back to my original theme. What an unexpected surprise! The deactivating of plugins is simple, the switching of themes is NOT.

    I have other topics out on the forum that are old which have been left unanswered. Please help me (and others) find a solution to this editor issue. I’m so disappointed in the forum support. We host our own website, are using a Windows Server and iis.

    Thank you!

    I just tried opening my WordPress Dashboard in FireFox instead of Internet Explorer (as I normally do), opened an existing page, and both the Visual and Text Editor tabs are showing up!!!! What’s up with that?!!!???

    Ok, so I just downloaded Internet Explorer 11 on our server. Now the Visual and Text Editor tabs are showing up. I have just deleted the script: define(‘CONCATENATE_SCRIPTS’,false); and the tabs are still showing.

    I activated all my plugins and the Visual and Text Editor tabs were still showing up but all of the content was missing (or invisible) while in Visual mode. After further research I discovered that my NextGEN Gallery plugin was causing the issue along with Internet Explorer. See “NextGEN plugin prevents WordPress edit in visual mode” which includes a fix for this. Imagely is recommending the “plugin” as the correction for IE11 users (I contacted them and it’s legit). I downloaded the plugin and now along with the IE update everything seems to be working normally. I hope this helps others experiencing the same problem.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘WordPress 4.8 Page Editor Does Not Work (Visual or Text)’ is closed to new replies.