Support » Plugin: Elementor Page Builder » WordPress 4.8 – New widgets not working

  • Resolved purbeckpixels

    (@purbeckpixels)


    None of the four new/updated widgets in WordPress 4.8 – Text / Image / Audio / Video – are working for me. I can drag them to a page but the options on the left don’t display. No errors in Console. All other WordPress/third party widgets working fine.

    WordPress 4.8, Elementor 1.4.8, Chrome 59.0.3071.86 (Ubuntu).

    • This topic was modified 1 year, 1 month ago by  purbeckpixels.
Viewing 10 replies - 1 through 10 (of 10 total)
  • @purbeckpixels

    I do believe that you have discovered a bug. I tried this on a couple test sites with the latest versions of everything and yep, nothing there in any of the new WP 4.8 widgets, not even the text widget!

    Cheers!
    Lyle

    Plugin Author ArielK

    (@arielk-1)

    I can confirm this bug, we’ll handle it as soon as possible.
    Thanks for your report.

    Weston Ruter

    (@westonruter)

    @purbeckpixels @snifflevalve @arielk-1 This has been reported on Trac, but not in related to Elementor. I haven’t been able to isolate the cause. If you can share any details there I would be grateful.

    Plugin Author ArielK

    (@arielk-1)

    We actually released a patch for this issue v1.4.9 Please update and let me know if this solved the problem

    Weston Ruter

    (@westonruter)

    @arielk-1 Is there anything that should be done for core as well?

    Plugin Author ArielK

    (@arielk-1)

    Hi @westonruter, thank you very much for your comment.

    In fact, if had an API for the new widgets, it would greatly help 3rd party developers like us to work properly.

    We had to do a hack for the compatibility with the new widgets. You can see the difference between the new version and the previous one regarding the compatibility:
    https://github.com/pojome/elementor/pull/1825/files#diff-147d758a7d52b0ad6a517f879728d359

    Weston Ruter

    (@westonruter)

    @arielk-1 What API do you need? I’ll also note that widgets will like be seeing some radical changes in the next year as they transition over to use blocks instead. I’ve sent you a DM on Slack to talk more.

    Philip Ingram

    (@pingram3541)

    This is great, I love seeing the Elementor team working with core devs, especially customizer/widget development! Weston, as always, you are amazing and I’m very grateful of you offering your help!

    @arielk FYI: Some additional changes have been made to the Text widget in 4.8.1. An RC1 release was built yesterday. You may want to re-test to ensure compatibility remains.

    Plugin Author ArielK

    (@arielk-1)

    @westonruter I did some tests on dev environment and everything looks fine, so thanks for your update!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘WordPress 4.8 – New widgets not working’ is closed to new replies.