Support » Plugin: ZodiacPress » WordPress 4.8.1

  • Resolved sunshine4nikki

    (@sunshine4nikki)



    I’m subscribed; please let me know when you’ve updated to Please update to WordPress 4.8.1 – this plugin is amazing.

Viewing 2 replies - 1 through 2 (of 2 total)
  • sunshine4nikki

    (@sunshine4nikki)

    I installed this 2-weeks ago and it didn’t work, so I contacted Isabel and received what obviously was an instant response message back (see below). I made sure I was up to date on everything stated in the letter (and my end was fine)… I tried installing ZodiacPress on an older version of WordPress and it works great. I wrote to Isabel several times so that I can get it working (anyone know PHP?). Except for the auto-response, I have not heard from her. It’s a shame, because the software looks great, but there is NO SUPPORT (it’s a free plugin though). Isabel, if you read this PLEASE UPDATE this plugin. Thanks.

    Hello,

    Im sorry that you experienced this, but this error means that your website hosting company is using an unsupported (outdated) version of PHP. This error will only happen with PHP version 5.3 or older. That has reached official “end of life” over 3 years ago. Running your website with that old version of PHP “may expose your site to security vulnerabilities” (see WordPress Requirements).
    WordPress recommends using at least PHP version 7. Although, ZodiacPress supports as old as PHP version 5.4.
    Most web hosting companies should have an option available for you to update the PHP version on your own. Log in to your web hosting account and have a look around. Look for your PHP version and you may find an easy way to update it.

    Please see this page for more information on this error: https://wordpress.org/support/topic/i-cannot-activate-current-1-4-1-version/

    Best regards,
    Isabel

    Plugin Author isabel104

    (@isabel104)

    Hi,

    This plugin is tested and works (and is working on several large sites) with WordPress 4.8.1, and PHP versions 5.4 and higher, including PHP 7.

    The response above is not an auto-response. Even though I do not provide one-to-one free email support, I took the time to respond personally to your email because your issue was a common error experienced by those with outdated PHP versions:

    Parse error: syntax error, unexpected '[' in /wp-content/plugins/zodiacpress/includes/class-zp-birth-report.php on line 141

    To be clear, that is not an error with the plugin. That is an incompatibility with older versions of PHP, which are older than version 5.4.

    Now, if your site is running on PHP version 5.4 or higher, then you will not experience that error. If you updated your PHP version and still experienced an error, I could try to help if you post here which PHP version you are running and who is your web host so that I can try to investigate the issue. There may be the possibility that you think your PHP version is updated, when it may not have actually been updated on your server.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘WordPress 4.8.1’ is closed to new replies.