Support » Plugin: Nav Menu Roles » WordPress 4.7 not working with Nav_Menu_Roles

  • Hi,

    After updating from WordPress 4.6.1 to 4.7 the site produces the following error:

    Fatal error: Class ‘Walker_Nav_Menu_Edit’ not found in /home/…./public_html/wp-content/plugins/nav-menu-roles/inc/class.Walker_Nav_Menu_Edit_Roles_4.7.php on line 12

    I’m unable to discover why the class is not registered as the file class-walker-nav-menu-edit.php is in the wp-admin\includes folder.

    Rolling back to wordpress 4.6.1 fixes the problem.

    Any help or a fix would be much appreciated.

    Cheers
    Philip

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author helgatheviking

    (@helgatheviking)

    Please try disabling other plugins and switching to a default theme (such as Twenty Sixteen). 95% of the time problems are due to a conflict with another plugin/theme that is trying to change the admin Walker.

    Hi,
    Thanks for the reply. I don’t think this is a conflict. I have not changed any plugins, the only difference is that WordPress was updated to version 4.7 and the site crashed with the error mentioned. Once I deleted the wordpress installation files (excluding /wp-content and wp-config.php) and uploaded version 4.6.1 files instead everything worked again.

    The only possibility I can see for a conflict is if another plugin interacts differently between those two wordpress versions, as everything else is the same.

    Cheers
    Philip

    Plugin Author helgatheviking

    (@helgatheviking)

    But that could mean that a conflicting plugin and/or theme has not updated it’s conflicting Walker to be compatible with 4.7, so please run through the basic debug steps. Ideally, use a staging site if you can.

    Also, this plugin I wrote may help.

    Hi,
    I have tested on a localhost server now and it is a conflict between nav_menu_roles & if_menu plugins.

    The wordpress 4.7 update must do something differently that causes a fatal error when both plugins are active – this did not happen in version 4.6.1

    Is this a case of waiting for a modification of WordPress or is there a method to make the plugins work together?

    Cheers
    Philip

    Plugin Author helgatheviking

    (@helgatheviking)

    Conflict with If Menu came up a few weeks ago, though I can’t find the thread now. The problem is in their admin notices. I’ve suggested some code to the If Menu author, see my pull request. I think especially the “Different approach to displaying admin notice.” commit was responsible for fixing the fatal conflict.

    Thanks very much – I’ll take a look

    Great help, once I disabled the If Menu plugin, problem solved in WordPress 4.7.2.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WordPress 4.7 not working with Nav_Menu_Roles’ is closed to new replies.