Support » Plugin: qTranslate » wordpress 3.9.1

Viewing 15 replies - 1 through 15 (of 27 total)
  • When will this plugin be aviable for WP 3.9.1?

    It’s urgent!

    Thank you!

    Subscribing.

    qTranslate simply is the best multilanguage plugin for WordPress. I’m looking forward to use it in WP 3.9.1 as well. Please update soon.

    Kind regards

    You can take some risks and change the constant QT_SUPPORTED_WP_VERSION in qtranslate.php (line 90) to 3.9.1.
    It seems to work OK.

    Catchable fatal error: Object of class WP_Post could not be converted to string in /public_html/wp-content/plugins/qtranslate/qtranslate_core.php on line 455

    As eskaigualker suggested the little hack within qtransalte.php worked OK for me as long as my site is already up and running and as long as I don’t plan to blog or add a lot of pages later.

    Else I experienced problems creating content while the plugin was running. Slugs got mixed and the body text simply disappeared.

    Seems qTranslate is dead. Even the related forums are not frequented. That’s when one guy is doing a software 🙁

    @globecore:
    I had this error when using get_the_date() function.
    In WP3.9.1, definition of get_the_date have been changed.
    return apply_filters( 'get_the_date', $the_date, $d, $post );
    instead of
    return apply_filters( 'get_the_date', $the_date, $d );

    Because of that function qtrans_dateFromPostForCurrentLanguage in qtranslate-core.php (line 459) need to be changed with adding a parameter in third position ($given_post just before $before)

    function qtrans_dateFromPostForCurrentLanguage($old_date, $format ='', $given_post = null, $before = '', $after = '') {
    	global $post;
    	return qtrans_strftime(qtrans_convertDateFormat($format), mysql2date('U',$post->post_date), $old_date, $before, $after);
    }

    This works for me.

    This guy isnt answering any questions for wp 3.9.x. 🙁

    So this plugin is for trashcan…….

    Maybe with some donations he can get some time to update this amazing plugin!?

    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    Maybe, but you’ll have to keep that presumption to yourself or contact the plugin author directly about it. It’s important that payment isn’t discussed on these forums.

    A fork …..

    mqtranslate

    mqTranslate is a fork of the well-known qTranslate plugin, extending the original software with collaborative and team-oriented features.

    Requires: 3.9 or higher
    Compatible up to: WordPress 4.0-alpha

    Oh thank you, marinae, a thousand times!!!

    If you go to the developer’s website (http://www.qianqin.de/qtranslate/download/) and download the development version, it solved the problem for me.

    Thks for your plugin. It’s very good for my job.

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘wordpress 3.9.1’ is closed to new replies.