Support » Fixing WordPress » WordPress 3.9 – Can't save drafts or publish posts when editing existing posts

  • Is anyone else having the issue that I am? Since updating to WP 3.9 a few days ago I am having issues with saving drafts (the button to save the draft never turns active) and also am unable to click the publish button as it never turns active. On existing posts I can from time to time do this and it seems to be selective when I am allowed to click save draft or publish and I have yet to find a pattern or reason for cause.

    Also like everyone else I was really peeved to find that my TinyMCE editor was basically blanked out and like everyone else I tried all the tricks and none of them worked so I am having to settle and quite unhappily mind you, for a far sub-par editor that I hate.

    I’m going to vent now. Whoever is running your I.T. department needs to go back to school and brush up on what user acceptance testing means. No one could have tested this, it’s just not possible because this was a nightmare release. I worked in product development for a major corporation for 15 years and this is so beyond acceptable it would be laughable if it weren’t so enraging.

Viewing 15 replies - 1 through 15 (of 22 total)
  • Generally speaking, understand that whatever problems you’re experiencing are unique to your site. Most other people are not having the same problems. Until you approach it with that in mind, you will have a difficult time resolving the issues your site is experiencing.

    So if you want to vent, fine. But if you want to fix the problems with your site, then venting isn’t very constructive.

    The master list has a big section on troubleshooting in the first post:
    https://wordpress.org/support/topic/wordpress-39-master-list?replies=6

    Have you tried that yet? Disabling plugins, flushing caches, etc? Knowing what you’ve tried goes a long way towards helping people figure out why your site is behaving differently than everybody else’s.

    I am having an issue like this as well, since the update to WordPress 3.9 I can’t publish any article. I actually can’t write them at all.

    I have tried the thing with plugins but it is still the same 🙁

    Anyone knows about this?

    Thank you!!!

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Also experiencing this “Can’t save drafts or publish posts problem”. Only answer so far seems to be to (copy the post elsewhere) then discard the changes and go at it again. I often write outside of WP, pasting in my text and doing a little formatting, so this isn’t a major issue. Even if you have to discard the post, you can also look at an autosave, it might bring you back to where you were, or at least close.

    Also experiencing this “Can’t save drafts or publish posts problem”.
    Also all items that are linked to anything else have lost the first part of the linke ie: http://www.example.com/link has been changed to http://jerusalemcats.com/link
    All my audio files had to be reattached to the pages. I hve over 700 audio files and podcasts and 38 seperate pages.
    I have also lost connection with the server and constant 500 errors.
    I have droped down to 24 plug ins from 34 plug in and it did not help.
    http://jerusalemcats.com

    I am having the same issue.

    Try to deactivate all plugins and activate. Didn’t help.

    I reinstalled the WP – didn’t help.

    What to do now?

    I was experiencing this issue and narrowed it down to the Autosave Draft function hanging. If anyone is using the Post Type Switcher plugin, that could be the problem.

    http://wordpress.org/support/topic/saving-draft-not-completing-in-wordpress-39

    Since the 3.9 update, I am having the same problem while trying to update my pages. When I click on the Update button, I get a pop-up that asks me to Leave or Stay on the Page! I am unable to save any changes! Please help!

    Seems that the CKEditor plugin like the TinyMCE editor was causing my issue with not being able to save my updates. I could save updates from the HTML tab, but not from the Visual tab. Now that I have deactivated the CKEditor plugin, I can update from the Visual tab as well.

    Will this interference with these “editor” plugins be fixed?

    Just tossing my note that I was having the same issue. Deactivating the Post Type Switcher plugin fixed the problem. Thanks thethunderbird99

    I had the same problem and deactivating Post Type Switcher fixed it. Thank you SO much. This problem was eating my soul.

    I have the same problem since upgrading to 3.9 : I can’t publish anything at all ! I uninstalled all my plugins and it was actually one of them which caused this problem : Advanced Custom Field. So I have downgraded to 3.8 until this bug is fixed.

    A workaround has been published here for this bug with ACF :
    http://support.advancedcustomfields.com/forums/topic/wp-3-9-validation-failed-disables-publish-button/

    I also have this issue, it realy sucks. can’t save and publish

    I’m having the same issue. I can’t save posts, pages and I can’t even deactivate my plugins. Every time I save a post it returns to the main post page… help!

    I’m having the same exact problem now. I am using WP 3.9. I’ve tried re-installing wordpress and disabling all plug-ins. Still unable to save a post.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘WordPress 3.9 – Can't save drafts or publish posts when editing existing posts’ is closed to new replies.