Support » Fixing WordPress » WordPress 3.8.1 is insanely slow on Dreamhost

  • Hi –

    I just purchased a domain from DreamHost and did the one-click install WordPress 3.8.1 on DreamHost. Here’s my site: It is a brand new site, and I don’t have many files or pictures on it.

    It’s running SO slowly that I can’t stand it anymore.
    Verifications of results:
    – tried different browsers
    – deactivated all plugins reports 6.702 seconds for first byte typically 7.81 seconds load time, page size 752.5kB
    – connecting to is near instant, so it’s something to do with WordPress and the Dreamhost servers.

    I saw there were many similar posts about the slowness of WordPress on DreamHost, and I thought the problem would have been resolved by now. Apparently it hasn’t.

    Does anyone have any trick in making the site back to normal, if not fast, speed?


Viewing 15 replies - 1 through 15 (of 17 total)
  • DreamHost_ElliceS


    DreamHost Support Rep

    Hi there!

    I see you were able to address the slow load issue with one of our LiveChat techs earlier today. 🙂 It looks like wp-super-cache seems to be helping, as I see your site loading pretty quickly now.

    If you run into any other issues or have any questions for us on our end, feel free to start another LiveChat or submit a ticket from the “Contact Support” link in the web panel.

    Ellice S
    DreamHost Staff

    I have the same problem, started few days ago in my domain
    google chrome and firefox debuggers say that it want about 3 sec to load, but some times the load time is more than 1 minute.

    bytecheck report say: Your Time To First Byte is: 3.889 seconds
    pingdom report say: Load time 9.68s

    10 days ago the site was running normally, but after a restart of apache it’s very very slow…
    it’s possible the problem is the last update of wordpress??

    vpistis, you have a plugin (or a theme) that isn’t playing nicely with PHP. I can tell because when I went to your site to check on things, wp-cli won’t run. That’s kind of my cheating way to make sure everything’s copacetic.

    I would trim out some of those plugins. The ones that strike me as possibly not needed right now…

    * p3-profiler (Good while debugging, not needed otherwise)
    * real-time-find-and-replace
    * disable-wordpress-updates
    * easy-pie-maintenance-mode
    * jquery-image-lazy-loading (oddly can make your site slower in some cases)

    Also you’re using these:

    * custom-javascript-editor
    * my-custom-css

    It’s highly possible you made a mistake with your custom JS that’s causing issues. I know I’ve done it a million times :/

    Ciao Ipstenu-DH,

    thanx for your help…

    I turned off some plugin and the dreamhost support (you? 🙂 ) have restarting apache…now it’s running normally…but I don’t think this is the problem, because is the same situation from few months.
    But if now resolve for a moment…it’s a good (temporary) solution…

    But other hand wp-cli doesn’t run…mmmh no good…I reinstall the last wp update…I hope this resolve the issue (obviously after a total backup)


    Not I with the reboot! But if Apache restarts are fixing it for a short while, then I’ll pass that info to our stability guys and see if it’s something they know about (likely, they’re smart) and are already working on.

    wp-cli not running means that a theme or plugin is punching PHP in the nose :/

    yes i know the reboot don’t resolve if there is a problem 🙁
    thanx for your support 😉


    The only way to debug the wp-cli stuff would be to turn off all the plugins, see if it works, and then turn ’em on one at a time until it breaks. Which is one of the most annoying things to do :/


    I am having the same issue. Support naturally dismisses the report.

    It runs slow even from a clean install. It seems like its waiting for something.

    Now do you guys think its dreamhost or wordpress?



    Forum Moderator

    @astroroxy: It is considered impolite to interrupt another poster’s ongoing thread unless you are posting a solution or suggestion. It causes significant problems for the forum’s volunteers and prevents us from being able to track issues by topic. Please post your own topic.

    I have the exact problem,

    Same as wmja4387 and vpistis

    I am not interrupting their post. In fact the original poster has not even responded.

    I do not see how this is rude.



    Forum Moderator

    These forums have guidelines. Please read them.

    As you will see, one of these guidelines – entitled Where to Post – specifically states:

    Unless you are using the same version of WordPress on the same physical server hosted by the same hosts with the same plugins, theme & configurations as the original poster, do not post in someone else’s thread. Start your own topic.

    Please abide by this.

    After numerous chats and email exchange with DreamHost, the problem was finally resolved. DreamHost moved my account to a different server, and I’m able to connect to my site ( without a problem.

    Thanks for the reply!


    for the moment I have resolved with apache restart and turning off some plugins …but for me I think the major slowness is due the distance of the servers italy-usa.


    wmja4387 – Sometimes the mix of domains on a server is bad 🙁 Sorry about that.

    vpistis – That’s often an issue and, since all our servers are in the US, not one I can easily solve. You may want to look into a CDN to speed things up.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘WordPress 3.8.1 is insanely slow on Dreamhost’ is closed to new replies.