WordPress.org

Support

Support » How-To and Troubleshooting » WordPress 3.8 upgrade issue

WordPress 3.8 upgrade issue

  • Hi,

    I’ve just upgraded my site to 3.8 and I’ve gotten an error message on my dashboard:

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function ‘wp_admin_bar_sidebar_toggle’ not found or invalid function name in (…)/public_html/wp-includes/plugin.php on line 507

    The site appears to be working fine but I’d still like to know what to do about this warning.

    Any advice would be greatly appreciated =)

    Thanks

    Jo

    http://thesummitnews.co.uk.gridhosted.co.uk

Viewing 12 replies - 1 through 12 (of 12 total)
  • dimitris33
    Participant

    @dimitris33

    do you still have it? did you disable your plugins ?

    robwakeman
    Member

    @robwakeman

    Hi

    A client of mine updated to 3.8 yesterday and has the same issue with exactly the same error message.

    The error still occurs after deleting all plugins.

    Thanks for any help
    Rob

    robwakeman
    Member

    @robwakeman

    By the way, the site URL is http://www.su-lynntan.com/

    Thanks
    Rob

    I’m getting the same error message as well. Any help would be greatly appreciated.

    robwakeman
    Member

    @robwakeman

    I did wonder if it was theme-specific. The site (see above) is currently using a child version of the theme Spun. But then I switched theme to Twenty Thirteen and the error message is still there. So, for me, it appears as if it’s not related to either plugins or theme.

    The source of the error is in wp-includes/plugin.php. The code in that file is the same as the original file from the WP installation i.e. it doesn’t appear as if it’s been corrupted or changed in any way.

    So, I don’t know how to solve this. Maybe the only thing is to completely re-install the site.

    Does anyone else have any suggestions?

    Thanks
    Rob

    robwakeman
    Member

    @robwakeman

    The bug seems to have magically disappeared! No idea why.

    Mine still exists. Did you do anything such as update or remove a plugin that may have helped?

    robwakeman
    Member

    @robwakeman

    The error message has reappeared! I’m now even more confused than I was before.

    jtmohatt, as you can see from my previous post, I have no plugins installed. Can I ask if you have any plugins and also which theme are you using? Thanks.

    I am using the Travelify theme and I have several plugins installed. Nothing was wrong until I upgraded to the latest version of WordPress.

    WebNoviceMel
    Member

    @webnovicemel

    I have the same problem. Am using Avada theme.
    My site is http://www.educationforsustainability.org.au/
    Have been looking through lots of online forums but haven’t found any answers. Any help much appreciated!
    -Mel

    robwakeman
    Member

    @robwakeman

    Joshaw’s original post states that the error message is on the dashboard. Just to clarify, I am seeing the PHP error message on all pages in the back end (admin) and the front end (website).

    For now, I’ve added a bit of code in wp-config.php which suppresses error messages (as a temporary sticking plaster), so the site doesn’t look messay, but it’s something I want to fix.

    I have updated other sites on the same host to 3.8 and this error doesn’t occur.

    I have no other solutions right now except to wait for the next WP update and hope that fixes it. If that doesn’t work, I guess it’s a complete re-installation and hope that does it.

    Oddly enough the error message has disappeared for me now.

    Maybe it’s a bug wordpress is working on and it’s slightly different for different themes?

    Will post on here if it comes back & if I find a solution elsewhere.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘WordPress 3.8 upgrade issue’ is closed to new replies.