WordPress.org

Support

Support » Plugins and Hacks » Black Studio TinyMCE Widget » [Resolved] WordPress 3.8

[Resolved] WordPress 3.8

Viewing 15 replies - 1 through 15 (of 21 total)
  • Yes – me also – 3.8 means that Black Studio Tiny MCE does not load correctly visually – a big problem. Hope someone can fix soon.

    Great I’m not the only one having this issue. Hopefully they will release A new update soon.

    Plugin Author Marco Chiesi

    @marcochiesi

    Hi there,
    I tested the plugin with WP 3.8 beta and detected no issues.
    Please could you describe which is the problem exactly and which theme are you using? You named a “Site Builder” plugin, I suppose you are referring to Page Builder by SiteOrigin, right?

    Plugin Author Marco Chiesi

    @marcochiesi

    P.S. I found a little glitch with the latest WP version that I didn’t notice before (I don’t know if it’s the same issue you are experiencing). To correctly initialize the widget you have to open it using the arrow/triangle on the right, and not just click on the widget title bar. I will hopefully fix it in next version.

    Below are two screen shots of my backend on WordPress you will notice the first link that Black Studios TinyMCE its screwed up. the other link is just a screen shot the other plugin Im using by SiteOrigin

    http://designquik.com/wp-content/uploads/2013/12/Screen-Shot-2013-12-13-at-7.47.46-PM.png

    http://designquik.com/wp-content/uploads/2013/12/Screen-Shot-2013-12-13-at-7.47.57-PM.png

    Thanks for the Help

    Plugin Author Marco Chiesi

    @marcochiesi

    Please try to temporarily disable the plugins that provide the buttons “Add Contact Form” and “Insert shortcode” and try again.

    Plugin Author Marco Chiesi

    @marcochiesi

    It looks like those two buttons are provided by Jetpack and Shortcodes Ultimate. I tried both but I was not able to reproduce your issue.
    I fear it can be a browser related problem. Could you try with another browser and/or to delete the cache?

    Hi – this might be a browser issue because I get the exactly the same problem as designquik – but in Firefox. In Chrome, IE and Opera it’s all good.

    It is a problem with plugins that add buttons that push the main edit suit of icons over to the right side, off the screen.

    I tried the disable plugins and re-enable but it didn’t help.

    Perhaps a design fix for Firefox in an update of the plugin? That would be great as Firefox is an essential tool for web development.

    Thank you!

    Yeap, firefox is the issues.. I guess I’ll work in Chrome now. Thanks Guys

    Plugin Author Marco Chiesi

    @marcochiesi

    A fix for this will be included in next release.
    In the meantime you can apply a manual fix by editing the black-studio-tinymce-widget.css file and add a clear: both; in the .editor_container selector:

    .editor_container {
        [...]
        clear: both;
    }

    Thank you Marco.

    Maybe it’s just me being dumb and not knowing css very well, but

    .editor_container {
        [...]
        clear: both;
    }

    doesn’t work but this did:

    .editor_container {
        clear: both;
    }

    Just for anybody else – don’t know what the square brackets were meant to mean.

    Anyhow – it all works now well – thanks!

    That works great! Thanks

    Plugin Author Marco Chiesi

    @marcochiesi

    Note: the […] was just a placeholder for the text that was already in there (several lines) and should stay in place. The only one to be added was clear: both;.

    I have the same issue with a messed up Black Studio visual editor with WordPress 3.8. I tried the CSS fix, but it has no effect with FireFox. I am using the Ultimate Tinymce plugin, which adds functionality to the standard Black Studio widget. The combination worked fine in the previous version of WordPress, but with 3.8, Black Studio can’t display the widget editing box properly (whether you click on the arrow or the name of the widget). As in other posts, the tabs for “Text” or “Visual” appear within the dashboard tools area and the editing area extends too far to the right, because the tools are pushed over by the “Media” button. Despite these cosmetic issues, fortunately the functions appear to work properly. I hope that the visual aspects can be corrected soon.

    thanks!

    Instead of Ultimate Tinymce, consider using TinyMCE Advanced and then add the fix above:

    .editor_container {
    clear: both;
    }

    Remember – the code needs to be added to the css of the Black Studio Widget plugin.

    This works for me … maybe for you too.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] WordPress 3.8’ is closed to new replies.
Skip to toolbar