Support » Fixing WordPress » wordpress 3.7 updated itself before I backed up

  • Resolved cwithnueyes


    I was going into my site to back up before I was going to update and when I tried to login I got the message it was already updating!
    Database Update Required

    WordPress has been updated! Before we send you on your way, we have to update your database to the newest version.

    The update process may take a little while, so please be patient.

    Update WordPress Database

    Please help, my site has a shop in it which I do not need to start making again!!
    Without my own backups are all my changes going to be lost?

Viewing 10 replies - 1 through 10 (of 10 total)
  • That message alarmed me a bit the first time I saw it, but I believe that comes at the end of the update process and all should be well.

    As leejosepho said, you’ll see that message once WordPress is done updating and is normal. As far as it already updating, some hosts will automatically update WordPress (I think if use a cPanel installer). As far as your data, it’s very important to make regular backups. But don’t worry, a WordPress update will only update core files and perhaps make changes to database tables. You shouldn’t lose data. But like I said, make sure to do regular backups.

    some hosts will automatically update WordPress (I think if use a cPanel installer)

    @cwithnueyes: If that is what happened, I would suggest disabling that service so you can be sure you have your backups made and have deactivated all plugins and switched to a default WordPress theme for the duration of the update you instigate when you want it to happen.

    Thanks Doug & Leejosepho. Great help fast 🙂

    I’ll check it worked out ok, I’m pretty sure I have backups of the main files I changed, just not the whole thing.
    I’m also going to change the auto update thingy.

    If you have at least a backup of your database, wp-config.php and your wp-content folder, everything else is easily replaceable!

    I put this together so I can try different things at different sites while becoming accustomed to using automatic updates:

    /**** Control Automatic Updates
    **** reference:
    **** more:
    *** note: Add to wp-config.php and remove the double-slash
    *** preceding any line or lines you might wish to employ.
    * note: By default, automatic updates are already enabled for minor core releases
    * (such as for maintenance and security releases) and for core translation files. */
    /** Also Enable Automatic Updates For Plugins */
    //add_filter( 'auto_update_plugin', '__return_true' );
    /** Also Enable Automatic Updates For Themes */
    //add_filter( 'auto_update_theme', '__return_true' );
    /**** Enable Non-Default Automatic Nightly "Bleeding Edge" Updates */
    //add_filter( 'allow_dev_auto_core_updates', '__return_true' );
    /**** Enable Non-Default Automatic Major Core Updates */
    //add_filter( 'allow_major_auto_core_updates', '__return_true' );
    /****** Disable Default Automatic Updates For Minor Core Releases */
    //add_filter( 'allow_minor_auto_core_updates', '__return_false' );
    /****** Disable Default Automatic Updates For Translation Files */
    //add_filter( 'auto_update_translation', '__return_false' );
    /******** Disable All Automatic Core Updates */
    //add_filter( 'auto_update_core', '__return_false' );
    /********** Completely Disable (via |add_filter|) All Automatic Updates */
    //add_filter( 'automatic_updater_disabled', '__return_true' );
    /************ Completely Disable (via |define|) All Automatic Updates */
    //define( 'AUTOMATIC_UPDATER_DISABLED', true );

    note: I posted the above before discovering a line such as add_filter( 'auto_update_plugin', '__return_true' ); apparently needs something preceding it in order to work, so most of the above is still on the drawing board! However, adding define( 'AUTOMATIC_UPDATER_DISABLED', true ); did *not* leave me staring at a blank screen.

    3.7 auto updates only do minor point release updates (security/bug fixes, like 3.7 -> 3.7.1). If you see “Database Update Required” then it’s likely your host is updating WordPress for you, as that suggests a bigger change. I don’t believe you should ever see “Database Update Required” for a minor point release update. I leave 3.7 auto-updates enabled for my sites, but do major updates (say 3.6.x -> 3.7) manually after testing plugin/theme compatibility on a staging site.

    The host auto-updating WordPress is completely unrelated to WordPress 3.7 auto updates. I know for a fact that if you install WordPress via cPanel at a shared host (like Bluehost or Dreamhost), then they will update WordPress. I can’t recall if there’s a way to turn that off or if you have to contact theme. I generally do my own install of WordPress instead of using cPanel.

    Yes, I have been able to turn that off at BlueHost, and the thought here now is to be able to tweak the WordPress settings…and I hope to be able to post a new thread here about that later today.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘wordpress 3.7 updated itself before I backed up’ is closed to new replies.